Project

General

Profile

Bug #2833

'Open' problem with new DarwinCoreDataSource actor

Added by Dan Higgins over 12 years ago. Updated over 11 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
actors
Target version:
Start date:
04/30/2007
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
2833

Description

Recently, the DarwinCoreDataSource actor was updated to allow species names to be input during workflow execution rather than having to drag a source to the work area from the Data tab by hand. This included removing the datadownload when the actor is first dropped in the work area and putting it into the 'fire' method.

This creates the problem that immediately after a DarwinCoreDataSource actor is dragged to the work area from the actor list or the data tab, one cannot 'Open Actor' from the right click window because the metadata for the QueryBuilder has not been downloaded yet! (A QueryBuilder error message appears.) After the actor has been fired once, then the QB can be opened.

Need to get the 'Open Actor' menu command to inialize things if actor has never been fired!

History

#1 Updated by Dan Higgins over 11 years ago

Uping the Severity because this bug causes a problem with DarwinCore actors newly dragged from the Data search panel. The problem is not obvious at this point and may be quite baffling to a new user.

#2 Updated by Dan Higgins over 11 years ago

Data is now downloaded when actor is first dragged to the work area, allowing access to the query builder

#3 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 2833

Also available in: Atom PDF