Project

General

Profile

Bug #2841

ESA Registry edit feature does not work with submitted data sets

Added by Callie Bowdish over 12 years ago. Updated over 10 years ago.

Status:
In Progress
Priority:
Normal
Assignee:
Category:
metacat
Target version:
Start date:
05/14/2007
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
2841

Description

I save a data set using the ESA Registry and then try to edit it (still with the registry). The following error comes up. "More occurrences of the tag dataset/access/allow found than that can be shown in the form. Please use Morpho to edit this document."

Jing suggests that since now we have two moderator groups, we have two access rules and the two rules is bigger than the one which we can show in the form.

The Online form will automatically add access rules. The user does not enter them in. A couple of weeks ago the new group esa-moderators was created: dc=org:cn=esa-moderators,dc=ecoinformatics,dc=org

Now the access rules generated look something like:
ALLOW:

[all]
uid=esaadmin,o=NCEAS,dc=ecoinformatics,dc=org
ALLOW:

[all]
cn=knb-prod,o=NCEAS,dc=ecoinformatics,dc=org
ALLOW:

[all]
cn=esa-moderators,dc=ecoinformatics,dc=org
ALLOW:

[read]
[write]
uid=Bowdish1,o=unaffiliated,dc=ecoinformatics,dc=org

The Bowdish1 is not my moderator account, but a user test account.

Please note that I am unsure if this feature ever worked. Most of my testing was done with my regular account with moderator rights and we thought that the moderator could not use the edit feature online. Also the NCEAS Skin has a bug listed about the edit feature not working 2644. I do not know if there is a relation to that bug and the ESA problem.

History

#1 Updated by Jing Tao over 12 years ago

Tonight, I modified the moderators number (reduced from 2 to 1). But new package still has the same problem. So the previous guess is wrong. I will set local test in my machine.

#2 Updated by Callie Bowdish over 12 years ago

Here is another problem area. For some unknown reason I had one success with using the Moderator account to give access to edit a data package. To do this I went to the View Submissions area clicked on a data set link and wrote a little note about revising the dp, then clicked on the revise button. Then I logged in as the user owner of the dp and WAS ABLE TO EDIT using the edit button. I think this is how we originally set it up. Once the dp is submitted by the owner it can only be edited with the ESA form after the moderator asks for revisions.

I tried to repeat this method but I got the following error after clicking on the revise button in the window where the moderator views the individual dps.

"Failure in requesting revision of docid: esa.42.1 ( Failed while updating the document with additional Metadata.) 3 data set(s) found for moderation"

The dps that had the revise button clicked after adding a little note (and got the failure response)are no longer viewable. I remember this happening before but I thought it was fixed. I could not find a bug for it.

(Note the revise button to the right of the list of dps available to view does not apear to respond. What happens when this gets clicked?????)  The only way to look at the individual dps is by clicking on the dp link. I think there is a problem with having the buttons on the right next to the dp list. It is confusing, because one does not know if they are working are not.

I think we need to iron out any additional needed dialog boxes. One for when the owner clicks on the edit feature but does not have rights if the moderator hasn't reviewed it. One for when the moderator writes a comment and clicks on the revise button. (Something like revision request sent).

#3 Updated by Jing Tao over 12 years ago

The reason why user couldn't edit the submitted document is in the cgi script, there is a rule that the access allow rules couldn't be less or greater than 3. Otherwise, user will get the error. I don't see any reason we need that (Probably I missed something). However I takes out the rule and register form seems working fine to me. I will ask callie to do more extensive testing on my test machine. If everything seems good to her. I will check in the changes I made.

#4 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 2841

Also available in: Atom PDF