Project

General

Profile

Bug #3029

NPE when trying to save semantic type

Added by Chad Berkley almost 12 years ago. Updated almost 12 years ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
semantics
Target version:
Start date:
12/14/2007
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
3029

Description

When trying to save a semantic type on a composite actor, I get an NullPointerException. To reproduce this bug do the following:

1) drag a composite to the canvas
2) rt. click and choose 'Semantic Type Annotation'
3) choose a type to add and click the >> button to add it
4) click "ok"

The ok button will pause in the depressed form then an NPE will appear on the console. The NPE looks like this:

[java] >>> getConceptId() = urn:lsid:localhost:onto:1:1#Actor
[java] >>> getConceptId() = urn:lsid:localhost:onto:2:1#GeneralPurpose
[java] >>> getConceptId() = urn:lsid:localhost:onto:2:1#Workflow
[java] >>> getConceptId() = urn:lsid:localhost:onto:2:1#LocalInput
[java] Exception in thread "AWT-EventQueue-0" java.lang.NullPointerException
[java] at org.kepler.sms.gui.PortSemanticTypeEditorPane.doCommit(PortSemanticTypeEditorPane.java:113)
[java] at org.kepler.sms.gui.SemanticTypeEditor._doCommit(SemanticTypeEditor.java:186)
[java] at org.kepler.sms.gui.SemanticTypeEditor.access$000(SemanticTypeEditor.java:53)
[java] at org.kepler.sms.gui.SemanticTypeEditor$1.actionPerformed(SemanticTypeEditor.java:129)
[java] at javax.swing.AbstractButton.fireActionPerformed(AbstractButton.java:1849)
[java] at javax.swing.AbstractButton$Handler.actionPerformed(AbstractButton.java:2169)
.......

History

#1 Updated by Chad Berkley almost 12 years ago

null was not checked on one of the port variables. this is now fixed.

#2 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 3029

Also available in: Atom PDF