Project

General

Profile

Bug #3059

EML citation section should include both organizationNames and individualNames

Added by ben leinfelder almost 12 years ago. Updated almost 11 years ago.

Status:
Resolved
Priority:
Normal
Category:
metacat
Target version:
Start date:
01/10/2008
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
3059

Description

The citation part needs to be pulled from creator/organization/organizationName and creator/individualName.
it should be <organizationName|individualName>.<pubDate>.<titlle>

[11:05am] matt: the XSL should be flexible enough to deal with both people and organizations in the creator field
[11:06am] matt: it should also list multiple if there are multiple in the metadata
[11:06am] matt: e.g.,
[11:06am] matt: Kruger J, Smith T, and SANParks. 1999. The importance of fig characteristics for fig wasp morphospecies and diversity.

for an example of one that needs help:
http://knb.ecoinformatics.org/knb/metacat/judithk.691.3/sanparks


Related issues

Is duplicate of Morpho - Bug #2981: Citations currently do not include, Data Registry Name, lsid and URL for domainResolved10/10/2007

History

#1 Updated by ben leinfelder almost 12 years ago

this requires changes in eml-identifier.xsl
specifically around this template:

<!--*************** displays dataset citation********-->
<xsl:template name="identifier">
.........

#2 Updated by ben leinfelder over 11 years ago

Adding the organization is done, but this xsl also includes LSID information with links to the datapackage using the "short form" url: hostname/context/metacat/scope.id.rev/skin.
Going to wait to see what shakes out with the turnkey-installer changes Chris is making- hopefully adding the server context path as an xslt parameter will be the solution (so that there is no hardcoding of "knb/metacat" as the context/servlet path.

#3 Updated by ben leinfelder about 11 years ago

we should address this in the token-replacement goodness of 1.9

#4 Updated by ben leinfelder about 11 years ago

this is not good...the citation on ESA site looks like this:
"http://data.esa.org/knb/metacat/esa.31.6/esa"
note that ESA has their Metacat deployed under the /esa context not /knb as is indicated by the citation url (the actual href is correct, however).

#5 Updated by ben leinfelder about 11 years ago

only display LSID for ESA skin. all other skins should not display LSIDs but should use the the short form URL to point to the server that is currently displaying the datapackage.

#6 Updated by ben leinfelder about 11 years ago

Committed change in eml CVS. Not sure how it should be tagged for being pulled into Metacat (during build). My hunch is that the existing XSLs will be tagged for both 2.0.1 and 2.1.0 with possible minor differences for 2.1.0. We'll need additional build.xml properties to differentiate the tags needed, etc.

#7 Updated by ben leinfelder about 11 years ago

  • Bug 2981 has been marked as a duplicate of this bug. ***

#8 Updated by ben leinfelder about 11 years ago

Migrated the properties contained in the skin.configs directory to the style/skins/* properties.
This can now be configured using the admin configuration. Currently only ESA skin allows you to edit the values for the LSID authority, registry name and server, but other skins can be supported if needed.
The skin.configs directory has been removed from svn, and references to them in the source code have been removed.

#9 Updated by ben leinfelder almost 11 years ago

TODO: create an additional 2.0.1 update for stylesheets so that 2.0.1 documents are displayed correctly WRT the shortform URL/LSIDs

#10 Updated by ben leinfelder almost 11 years ago

Added RELEASE_EML_2_0_1_UPDATE_7 tag to EML cvs project with the eml-identifier.xsl change included.
Metacat is now pulling that tag for the 2.0.1 styles with the LSID fix, etc...

#11 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 3059

Also available in: Atom PDF