Project

General

Profile

Bug #3064

DBA: check that plot names match project code

Added by Michael Lee almost 13 years ago. Updated over 12 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
EntryDB
Target version:
Start date:
01/12/2008
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
3064

Description

SQL to accomplish that:
SELECT project.projectName, project.entry_projectCode AS [project Code], observation.authorObsCode AS obsCode, observation.authorPlotCode AS plotCode_entry, plot.authorPlotCode AS plotcode_archive, IIf(startsWith([observation].[authorObsCode],[entry_projectCode] & "-") And startsWith([observation].[authorPlotCode],[entry_projectCode] & "-") And startsWith(nz([plot].[authorPlotCode],[entry_projectCode] & "-"),[entry_projectCode] & "-"),True,False) AS allOK
FROM (observation LEFT JOIN plot ON observation.PLOT_ID = plot.PLOT_ID) LEFT JOIN project ON observation.PROJECT_ID = project.PROJECT_ID;


Related issues

Has duplicate InfoVeg - Bug #3009: Check that plots are named according to their project labelResolved11/22/2007

History

#1 Updated by Michael Lee over 12 years ago

this is the same thing as bug 3009 exactly!

  • This bug has been marked as a duplicate of bug 3009 ***

#2 Updated by Redmine Admin over 7 years ago

Original Bugzilla ID was 3064

Also available in: Atom PDF