Project

General

Profile

Bug #3129

links exist to ptII demos that do not work

Added by Chad Berkley almost 12 years ago. Updated almost 12 years ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
core
Target version:
Start date:
02/05/2008
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
3129

Description

There are links in the documentation for kepler to ptII demos that don't work. These demos need to be pulled out. The plan is to create a list of ptII demos that do work and eliminate the link to the ptolemy documentation from which they are currently linked.

History

#1 Updated by Christopher Brooks almost 12 years ago

If you tell me what demos to exclude, I can update
completeDemosPtinyKepler.htm in the rel-7-0-beta-2 branch and the trunk

That file is derived from completeDemos.htm by running "make update"
in that directory. What links end up in completeDemosPtinyKepler.htm
is determined by file directives
<!--/ptinyKeplerDocs-->
<!--ptinyKeplerDocs-->

I excluded SmartSender from completeDemosPtinyKepler,
both the ptII trunk and the rel-7-0-beta-2,
though I'm not sure why SmartSender is not in Kepler1.0.0rc1.
However, I think it is fine not to include it.
Below is my original post about the missing demo.

  • The Splashscreen has a "Documentation" link that leads to
    "Background information" on Ptolemy.

Background information leads to completePtinyKeplerDemos.htm
which has a link under DE to SmartSender

ptolemy/domains/de/demo/SmartSender/SmartSender.xml is not found.

To check for this, go to the Ptolemy copyright link and click
"Other copyrights about this configuration"
which goes to another page, click
"Other information about this configuration" on the new page

Then click "Open the .htm, .html, .xml and pdf" for
completeDemosPtinyKepler.htm.

#2 Updated by Christopher Brooks almost 12 years ago

I looked into this, and I think the problem is that I was running out
of memory, see http://bugzilla.ecoinformatics.org/show_bug.cgi?id=3106

SmartSender is present, I can open it.

However, if I remove it from completeDemosPtinyKepler.htm, then opening
all the demos fails on the next model.

#3 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 3129

Also available in: Atom PDF