Project

General

Profile

Bug #3131

R is not added to the path

Added by Chad Berkley over 11 years ago. Updated over 11 years ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
installer
Target version:
Start date:
02/05/2008
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
3131

Description

The errors cxh got with R seem to be coming from the fact that R is installed, but not put into the path on windows. I'm trying to figure out how to do that with IzPack right now.


Related issues

Is duplicate of Kepler - Bug #3133: R is not added to the pathResolved02/05/2008

Blocks Kepler - Bug #3101: Inclusion of R executable for Mac and Linux ?Resolved01/24/2008

History

#1 Updated by Dan Higgins over 11 years ago

You should not need to add R to the path if it is installed with the installer. If the R.zip is installed inside $KEPLER, the RExpression actor will find it.

If not installed inside Kepler, it will need to be on the path (and adding something to the Path permanently is not easy in Windows).

Dan

#2 Updated by Chad Berkley over 11 years ago

  • Bug 3133 has been marked as a duplicate of this bug. ***

#3 Updated by Chad Berkley over 11 years ago

The error is actually with the ExternalExec actor in the 08-CommandLine_2.xml demo. It tries to call R on the command line, which fails if R is not in the path.

#4 Updated by Chad Berkley over 11 years ago

R is now added to the path on windows. We are not including the R installation for the mac or linux installer so i'm going to wait for the resolution of bug 3101 before I worry about doing the same for osx/linux.

#5 Updated by Chad Berkley over 11 years ago

I'm closing this because right now, the only way to get R to work on linux or mac is to install it yourself and put it in the path. when bug 3101 is resolved, this can be revisited.

#6 Updated by Redmine Admin about 6 years ago

Original Bugzilla ID was 3131

Also available in: Atom PDF