Project

General

Profile

Bug #3176

Verify existing token changes to skins

Added by Michael Daigle over 11 years ago. Updated over 11 years ago.

Status:
Resolved
Priority:
Normal
Category:
metacat
Target version:
Start date:
03/13/2008
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
3176

Description

Test the token changes that Chris and Ben made to the skins for the 1.8.1 release.

History

#1 Updated by Michael Daigle over 11 years ago

Advanced Search results were not formatted correctly due to path changes in the resultset xsl file. Added the contextURL parameter to the transform.

#2 Updated by Jing Tao over 11 years ago

Hi, mike:

When i test kepler skin and found there is an error:
http://chico.dyndns.org/kepler/style/skins/kepler/resultset.xsl; Line #50; Column #74; org.apache.xml.utils.WrappedRuntimeException: Could not find variable with the name of contextURL

This file is metacat/lib/style/skins/kepler/resultset.xsl

It seems "contextURL" couldn't be find. Would you please take a look?

Jing

#3 Updated by Jing Tao over 11 years ago

In search result page of kepler skin, you click "View documentation" link and will get an blank page. The catalina.out shows this error message - http://chico.dyndns.org/kepler/style/skins/kepler/entity.xsl; Line #50; Column #74; org.apache.xml.utils.WrappedRuntimeException: Could not find variable with the name of contextURL

In same result page, if you click "Download" button, it will go to an url like: http://{$httpserver}/authority/data?lsid=urn:lsid:kepler-project.org:kar:236:1

You see, there is a {$httpserver} in the url.

#4 Updated by Michael Daigle over 11 years ago

Removed the extra "/" in the config-dir path. This wasn't hurting anything, but it made it look like something didn't get populated correctly in the path.

#5 Updated by Michael Daigle over 11 years ago

Some of the skins xml files were missing a leading "/" on the path to the acsii-treeview.xsl file. This means the default ascii treeview was not available. Made the change and submitted.

#6 Updated by Callie Bowdish over 11 years ago

obfs, nrs, esa skin have problems with displaying the header, the South African skins need to be checked too.

Here is an example:
http://dev.nceas.ucsb.edu/cgi-bin/register-dataset.cgi?cfg=nrs

Here is the error:

HTTP Status 404 - /cgi-bin/style/skins/nrs/header.jsp
type Status report

message /cgi-bin/style/skins/nrs/header.jsp

description The requested resource (/cgi-bin/style/skins/nrs/header.jsp) is not available.

#7 Updated by Callie Bowdish over 11 years ago

Looks like the register-dataset part needs looking at too. From the nrs skin a clicked on register data set after logging in. I think we need to test all of the login parts for the skins like esa, obfs, nrs and maybe the South African ones after the fix is made.

HTTP Status 404 - /knb/{$cgi-prefix}/register-dataset.cgi

type Status report

message /knb/{$cgi-prefix}/register-dataset.cgi

description The requested resource (/knb/{$cgi-prefix}/register-dataset.cgi) is not available.
Apache Tomcat/5.5.26

#8 Updated by Callie Bowdish over 11 years ago

login feature for nrs, esa, obfs has header problem with the create a new password, and reset password sections.

When these links for new password and reset password or clicked you get:

address:
http://dev.nceas.ucsb.edu/cgi-bin/ldapweb.cgi?cfg=obfs

error:
Not Found

The requested URL /cgi-bin/ldapweb.cgi was not found on this server.
Apache/2.0.52 (Red Hat) Server at dev.nceas.ucsb.edu Port 80

#9 Updated by Jing Tao over 11 years ago

callie: ldapweb.cgi wasn't installed in dev. I just intsalled it.

However, when i click the the link, there is still problem:
HTTP Status 404 - /cgi-bin/style/skins/obfs/header.jsp

type Status report

message /cgi-bin/style/skins/obfs/header.jsp

description The requested resource (/cgi-bin/style/skins/obfs/header.jsp) is not available.

Shawn could you take a look? Thanks.

#10 Updated by Callie Bowdish over 11 years ago

The login and form submission parts of the ESA, NRS, and OBFS are not working correctly. After submitting a form on the ESA I get this message.

"Failure
An error occurred. Please check the list of errors below:

  • Authentication failed for user: uid=esaadmin,o=NCEAS,dc=ecoinformatics,dc=org * Failed during login for admin.

Click here to return to the"

I don't think the user account I used was a member of esaadmin.

When submitting the NRS skin form I got a blank page.

I was unable to use the ESA skin to create an unaffiliated account.

In general the login part seems to be unstable on the ESA, NRS, OBFS sites.

#11 Updated by Jing Tao over 11 years ago

I think the reason is we didn't put the password into the .cfg files. Now I put them into esa.cfg and nrs.cfg.

Callie, do you know what is for obfs? I did restart tomcat in dev, i think it will okay.

Callie, would you please give another try? Thanks!

#12 Updated by Callie Bowdish over 11 years ago

ESA site does not work correctly

The Moderator feature does not work the same as the production one. It is also very slow.

Login spins until I choose a page - the redirect does not work

The view submission brings up 179 data set(s) found for moderation. (I realize we are working with test data.) ESA data sets are included in the result set but others are too.

When I click to moderate a data set It opens the moderator window with the Moderator Actions section with a text box for comment and buttons for Accept, Decline and Revise but on the right side is an error report with this text


This XML file does not appear to have any style information associated with it. The document tree is shown below.

<error>
the requested docid 'esa.52' does not exist
</error>


#13 Updated by Michael Daigle over 11 years ago

Verified that all skins are working

#14 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 3176

Also available in: Atom PDF