Project

General

Profile

Bug #3250

windows exe opens dos box

Added by Chad Berkley almost 11 years ago. Updated almost 11 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
installer
Target version:
Start date:
04/29/2008
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
3250

Description

try to make the kepler.exe file not open a dos box with windows.

History

#1 Updated by Chad Berkley almost 11 years ago

I don't see how to easily do this, so I'm going to leave it as is.

#2 Updated by Christopher Brooks almost 11 years ago

Kepler.exe is created using Launch4j.
Docs are at http://launch4j.sourceforge.net/docs.html#Configuration_file
Ptolemy also uses Launch4j, but does not have a DOS console.

installer/build/launch-kepler.xml has the line:
<headerType>console</headerType>

ptII7.0.1/adm/gen-7.0/ptII7_0_1_setup_l4j.xml has:
<headerType>gui</headerType>

This might do it.

Another thing is to look at stayAlive.
Kepler:
<stayAlive>false</stayAlive>
Ptolemy:
<stayAlive>true</stayAlive>

One advantage to the DOS console is that stdout is preserved and
available to the user. However, this is not very polished, instead
stdout should be remapped to a log file. Most applications that
are invoked from a menu choice do not bring up a dos window.

I'm reopening this pending the above changes.

#3 Updated by Daniel Crawl almost 11 years ago

The configuration was changed from gui to console so that stdout would appear.
I'm not sure sending it to a log file is appropriate in all cases, e.g.,
kepler.exe -h

#4 Updated by Christopher Brooks almost 11 years ago

I'm removing the block on 3245 for this bug, but leaving
it open. I'm also changing this to an enhancment.
Feel free to override.

The DOS window is an intended feature, not a bug.

I feel that the .exe should not open the DOS window, but having
the stdout and stderr is important. A case could be made
that this should be logged somewhere rather than disappearing.

The fix for this bug is: If kepler.exe is invoked from a menu,
then stderr and stdout should be redirected to log file.
If kepler.exe or kepler.sh is invoked from a command line,
then it would be nice if stderr and stdout appeared in the command line.

#5 Updated by Christopher Brooks almost 11 years ago

Reopening this an an enhancement (Forgot to leave it open last time).

#6 Updated by Chad Berkley almost 11 years ago

maybe as a compromise, we could have kepler.exe and kepler-console.exe. The first would not open the dos box, the latter would. The default would be kepler.exe (i.e. the shortcuts in the start menu and desktop would point to it).

#7 Updated by Daniel Crawl almost 11 years ago

kepler.exe has been changed back to a gui application and kepler-console.bat
added. (We chose .bat instead of .exe so that users can see the java command
to invoke kepler).

#8 Updated by Redmine Admin almost 6 years ago

Original Bugzilla ID was 3250

Also available in: Atom PDF