Project

General

Profile

Bug #3251

Installer Splash Screen should be an HTML Widget

Added by Christopher Brooks about 11 years ago. Updated almost 10 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
installer
Target version:
Start date:
04/30/2008
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
3251

Description

Is there anyway to use an HTML widget for the Installation Screen here?
The Ptolemy IzPack Installer uses an HTML widget, it looks more polished.
The text widget in courier looks primitive.
The links to the open bugs list is long and awkward, cutting and pasting is
difficult. I'm not sure if the IzPack HTML widget supports opening links though.


Related issues

Blocked by Kepler - Bug #3949: Get the installer working with the new build systemResolved04/06/2009

History

#1 Updated by Christopher Brooks about 10 years ago

I'm the reporter on this, it was assigned to Dan Higgins, I'm reassiging
it to Chad for his configuration. The issue is that the izPack installer
should use the HTML widget for the installation screen.
In the ptII tree, see
ptII/adm/gen-7.0/ptII7_0_devel_setup.xml

where I have

<res id="HTMLInfoPanel.info" src="index.htm"/>
<res id="HTMLLicencePanel.licence" src="copyright.htm"/>
<res id="InfoPanel.info" src="../../README.txt"/>
...
<panels>
<panel classname="HelloPanel"/>
<panel classname="HTMLInfoPanel"/>
<panel classname="HTMLLicencePanel"/>
<panel classname="TargetPanel"/>
<panel classname="PacksPanel"/>
<panel classname="SummaryPanel"/>
<panel classname="InstallPanel"/>
<panel classname="ShortcutPanel"/>
<panel classname="FinishPanel"/>
</panels>

#2 Updated by Chad Berkley almost 10 years ago

I'm going to close this for now. If someone really doesn't like the textual readme, I guess we can change it but it seems ok to me.

#3 Updated by Christopher Brooks almost 10 years ago

The problem is that the links in the installer screen are not mouse sensitive.
A textual installer readme screen looks less polished.
This is a really quick fix in izPack, just use HTMLInfoPanel, see this
bug for details.

#4 Updated by Chad Berkley almost 10 years ago

Ok, readme is now an html document.

#5 Updated by Redmine Admin about 6 years ago

Original Bugzilla ID was 3251

Also available in: Atom PDF