Project

General

Profile

Bug #3264

workflow ENM/ASC2RAWTest gives an exception under ubuntu

Added by Derik Barseghian about 11 years ago. Updated about 11 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
general
Target version:
Start date:
05/01/2008
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
3264

Description

This workflow needs to be removed or fixed for release

Running under Ubuntu gives an exception that starts with: "For input string: [very long string of squares with some other characters at the end]"

If you display stack trace, it's a java.lang.NumberFormatException. The problem is likely in AscToRaw.java


Related issues

Blocked by Kepler - Bug #3245: Release 1.0 installer tracking bugResolved04/29/2008

History

#1 Updated by Derik Barseghian about 11 years ago

added that this blocks 3245

#2 Updated by Dan Higgins about 11 years ago

This workflow seems to run fine on a Mac. This suggests that the problem is not with the workflow (ie a platform specific problem)

#3 Updated by Jing Tao about 11 years ago

Dan, did you try run twice? Sometimes, the first time worked, but the second time failed.

#4 Updated by Jing Tao about 11 years ago

I just tried in mac too. The first time, the workflow worked. However, it failed when i clicked the run button at the second time.

#5 Updated by Dan Higgins about 11 years ago

I also see the error on 2nd run problem on the Mac. So ignore comment #2

If one deletes the *.raw files created the first time, then the error goes away! It looks like the problem is related to the existence of raw files when the wf is executed. (Problem overwriting existing files ?)

Dan Higgins

#6 Updated by Chad Berkley about 11 years ago

This looks like a problem with AscToRaw.getHeaderInformation(). The error handling for missing header information is not working. there is only a print statement in one of the try/catch blocks.

#7 Updated by Chad Berkley about 11 years ago

fixed. the directory listing actor was pulling in all the files in the lib/testdata/garp directory instead of just the *.asc files. it was trying to read files that weren't the right format and failing. The error handling in AscToRaw.java needs to be reworked post 1.0. There are several try/catch statements with wither nothing in the catch or just a System.out.

#8 Updated by ben leinfelder about 11 years ago

runs successfully (multiple times) on both OSX and Linux (v3 installer)

#9 Updated by Jing Tao about 11 years ago

Tried v3 in ubuntu, mac and windows. It works.

#10 Updated by Aaron Aaron about 11 years ago

runs on windows and OSX (v3 installer)

#11 Updated by Redmine Admin about 6 years ago

Original Bugzilla ID was 3264

Also available in: Atom PDF