Project

General

Profile

Bug #3363

Show name checkbox does nothing for most Parameters

Added by Derik Barseghian over 11 years ago. Updated over 10 years ago.

Status:
Resolved
Priority:
Normal
Category:
general
Target version:
Start date:
06/03/2008
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
3363

Description

steps to reproduce:
- Drag Parameter to canvas
- Right click, Customize Name
- Check or uncheck the Show Name box

The Show name box doesn't seem to work and is often unchecked by default (which seems like a bad choice for default).

This affects:
GriddlesParameter
ColorParameter
FileParameter
Parameter
PortParameter
RequireVersion
SemanticTypeParameter
StringParameter

History

#1 Updated by Christopher Brooks over 11 years ago

I'm not sure about this one.
In 2001, Edward wrote:

I've added a mechanism for controlling whether the name of an
entity is shown. Unfortunately, it wasn't possible to do this
right without having a backward compatibility problem... Now,
all models that have old-style labels will now show the names
of the visible attributes...

To fix this, just select the label and right click and select
Customize Name. The unselect the "show name" item.

actor.gui.RenameConfigurer looks like:
--start--
// By default, names are not shown for ports, and are shown
// for everything else. Note that ports are a little confusing,
// because names are always shown for external ports inside
// a composite actor. This dialog determines whether they will
// be shown on the outside of the composite actor.
boolean nameShowing = false;

if (object instanceof Port) {
nameShowing = _isPropertySet(_object, "_showName");
} else {
nameShowing = !_isPropertySet(_object, "_hideName");
}
addCheckBox("Show name", "Show name", nameShowing);

--end--
However, we have a different way of renaming ports now, so I
suspect that we can get rid of the "Show name" checkbox.

Edward?

#2 Updated by Christopher Brooks over 10 years ago

Fixed!
The solution here was to edit ptolemy/actor/gui/RenameConfigurer.java
and not add the "Show name" checkbox if the object is an Attribute.

#3 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 3363

Also available in: Atom PDF