Project

General

Profile

Bug #3448

stmml.xsd non-deterministic

Added by Margaret O'Brien over 13 years ago. Updated over 13 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
eml - general bugs
Target version:
Start date:
07/11/2008
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
3448

Description

A section of stmml.xsd is invalid, according to a new parser feature that Jing just added in response to bug 3232, and also to the venerable parsers in xmlSpy and oxygen. Interestingly, the 2 commercial editors don't catch up the error unless the schema is loaded directly, instead of imported (ie, by attribute.xsd).

This bug is very similar to 2054 -- that plagued EML for so long.

Here is the offending snip from stmml.xsd, starting at line 1708. The problem is the unbounded "definition" right next to the <xs:choice>

It appears that the invalidity can be fixed by either removing the minOccurs (ie, making it required) or by removing the <element ref="definition" ...> altogether. The sequence followed by choice structure makes any combination of elements ok, so this declaration seems to be extra. I do not see a more recent stmml.xsd available (cml.sourceforge.org). And we shouldn't go trekking of with our own flavor of stmml, so awaiting recommendations.

&lt;xsd:sequence&gt;
&lt;xsd:element ref="definition" minOccurs="0"/&gt;
&lt;xsd:choice minOccurs="0" maxOccurs="unbounded"&gt;
&lt;xsd:element ref="alternative"/&gt;
&lt;xsd:element ref="annotation"/&gt;
&lt;xsd:element ref="definition"/&gt;
&lt;xsd:element ref="description"/&gt;
&lt;xsd:element ref="enumeration"/&gt;
&lt;xsd:element ref="relatedEntry"/&gt;
&lt;/xsd:choice&gt;
&lt;/xsd:sequence&gt;

Related issues

Has duplicate EML - Bug #3445: stmml.xsd non-deterministicResolved07/10/2008

History

#1 Updated by Margaret O'Brien over 13 years ago

This is a duplicate of bug 3445

  • This bug has been marked as a duplicate of bug 3445 ***

#2 Updated by Redmine Admin almost 9 years ago

Original Bugzilla ID was 3448

Also available in: Atom PDF