Project

General

Profile

Bug #3720

uninitialized value error when trying to create new login account on dev

Added by Michael Daigle almost 11 years ago. Updated almost 11 years ago.

Status:
Resolved
Priority:
Immediate
Category:
metacat
Target version:
Start date:
01/02/2009
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
3720

Description

After submitting the information to create a new login account on dev, the next page has no information (skin frames only). I reproduced this for nceas and esa skins.

The apache error log shows the following when going to the "Create a new account screen":

[Fri Jan 02 16:55:08 2009] [error] [client 128.111.242.186] Use of uninitialized value in concatenation (.) or string at /var/www/edu.ucsb.nceas.dev/knb/cgi-bin/ldapweb.cgi line 127., referer: http://dev.nceas.ucsb.edu/knb/cgi-bin/ldapweb.cgi?cfg=esa

The apache error log shows the following after entering information and hitting the register button:

[Fri Jan 02 16:55:08 2009] [error] [client 128.111.242.186] Use of uninitialized value in substitution (s///) at /usr/lib/perl5/site_perl/5.8.5/Net/LDAP.pm line 107., referer: http://dev.nceas.ucsb.edu/knb/cgi-bin/ldapweb.cgi?cfg=esa
[Fri Jan 02 16:55:08 2009] [error] [client 128.111.242.186] Use of uninitialized value in substitution (s///) at /usr/lib/perl5/site_perl/5.8.5/Net/LDAP.pm line 109., referer: http://dev.nceas.ucsb.edu/knb/cgi-bin/ldapweb.cgi?cfg=esa
[Fri Jan 02 16:55:08 2009] [error] [client 128.111.242.186] Use of uninitialized value in substitution (s///) at /usr/lib/perl5/site_perl/5.8.5/Net/LDAP.pm line 110., referer: http://dev.nceas.ucsb.edu/knb/cgi-bin/ldapweb.cgi?cfg=esa
[Fri Jan 02 16:55:08 2009] [error] [client 128.111.242.186] Use of uninitialized value in substitution (s///) at /usr/lib/perl5/site_perl/5.8.5/Net/LDAP.pm line 141., referer: http://dev.nceas.ucsb.edu/knb/cgi-bin/ldapweb.cgi?cfg=esa

History

#1 Updated by Shaun Walbridge almost 11 years ago

It looks like the ldapweb.cgi hasn't been updated for the most recent round of properties changes, and needs to have various values set which don't currently exist directly within metacat.properties.

#2 Updated by Shaun Walbridge almost 11 years ago

Updated ldapweb.cgi with proper properties definitions, is correctly generating pages but still needs further testing, especially of special cases like ESA accounts.

#3 Updated by Shaun Walbridge almost 11 years ago

Fixed by making ldapweb.cgi match the current properties used by Metacat.

#4 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 3720

Also available in: Atom PDF