Project

General

Profile

Bug #3816

Export action doesn't create complete package

Added by Shaun Walbridge over 10 years ago. Updated over 6 years ago.

Status:
Closed
Priority:
Urgent
Category:
metacat
Target version:
Start date:
02/09/2009
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
3816

Description

When using the export action, two bugs are noticeable:

1. Documents with associated data tables have files with the data table names included, but no data contained within:

http://knb.ecoinformatics.org/knb/metacat?action=export&qformat=nceas&docid=nceas.912.8

2. The resulting files are named after the docid and not based on our sensible naming logic (e.g. mbauer.5 instead of nceas.912.8-mbauer.5.2-Benicia_CABE-107-1.txt). Check with Jim / Rick as to their preference. Probably in the context of the package, the metadata docid is superfluous, and the docid-filename form is correct (mbauer.5.2-Benicia_CABE-107.1.txt).

History

#1 Updated by Shaun Walbridge over 10 years ago

Add an explicit test for this action, by uploading a new document with associated files, then downloading the resulting zip file and SHA1 summing each of the returned results. This'll insure that the action works across EML changes.

#2 Updated by Matt Jones over 10 years ago

Mike,

This Metacat export bug is 1) a regression from prior behavior, and 2) sorely needs fixing for the NCEAS collaborative working groups. I'm retargeting this as 'critical' to up its priority. If you can fit this in for the 1.9.0 release that would be ideal, although I fully understand if that is not possible due to testing constraints, which is why I left it pointing at 1.9.1.

Matt

#3 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 3816

#4 Updated by ben leinfelder over 6 years ago

  • Target version changed from Unspecified to 2.1.0
  • Priority changed from Normal to Urgent
  • Assignee changed from Michael Daigle to ben leinfelder

Well, instead of a zip file, I get the XML error message but as if it were a .zip file download:

<?xml version="1.0"?>
<error>
No guid registered for docid nceas.912.912
</error>

So this is even worse now in v2.0.x

#5 Updated by ben leinfelder over 6 years ago

  • Status changed from New to Closed

this has been corrected in trunk and will be included in the next release built from trunk.

Also available in: Atom PDF