Project

General

Profile

Bug #3942

Report Designer - add/edit item labels

Added by ben leinfelder about 10 years ago. Updated almost 10 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
reporting
Target version:
Start date:
04/03/2009
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
3942

Description

Now that we have Items dragging around on the report, we should be able to add labels to them:
-Drag a label item from the list on the left to a location relative to the Item already on the report (N/S/E/W).
-Show a text area for users to enter the text.
-That text become the ItemLabel text for that label with the given position.


Related issues

Is duplicate of Kepler - Bug #3956: Report Designer - item label editingResolved04/07/2009

Blocks Kepler - Bug #4189: Report Designer - Dynamic Report Item labels are not rendering correctlyClosed06/26/2009

History

#1 Updated by ben leinfelder about 10 years ago

to clarify: we're already handling this in from the RIO side of things...just need to put it in the UI for the user to interact with.

#2 Updated by ben leinfelder about 10 years ago

  • Bug 3956 has been marked as a duplicate of this bug. ***

#3 Updated by ben leinfelder about 10 years ago

some more comments from my dupe:
---
An Item Label should be dragged to an existing ReportItem.
1. The label provides a text area for editing the label.
2. The label's properties will include its position relative to the Item and
also whether it should be repeated in cases where there are more than one
ItemValues per Item.

For the "first pass" of this, just implement a simple label without worrying
about configured positioning (#1 above)

#4 Updated by ben leinfelder about 10 years ago

we definitely need labels for the items

#5 Updated by debi staggs almost 10 years ago

A custom panel for a dynamic report item has been created that provides text fields in the North, South, West, and East positions around the icon, but the content of the fields is not yet being added correctly to the report model.

#6 Updated by debi staggs almost 10 years ago

We can add the labels, but there is a bug with the labels and the model not being in sync.

#7 Updated by debi staggs almost 10 years ago

This bug has been fixed, and is now working.

#8 Updated by Redmine Admin about 6 years ago

Original Bugzilla ID was 3942

Also available in: Atom PDF