Project

General

Profile

Bug #4034

"Invalid memory access" when running workflow from the command line

Added by Chad Berkley over 10 years ago. Updated about 10 years ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
core
Target version:
Start date:
04/29/2009
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
4034

Description

When running even very simple workflows from the command line, Kepler fails with the following output. For some reason, I can't reproduce this on windows. The invalid memory access error makes me think maybe the jar file was created on windows and is, for some reason, not valid on osx. Maybe a missing byte or something.

berkley@Slickrock kepler$ ./kepler.sh runwf -gui common/demos/test.xml
args: -runwf -gui common/demos/test.xml
[null] loading: ptolemy.actor.gui.PtExecuteApplication args: [Ljava.lang.String;@480773
[null] 659 ms. Memory: 9076K Free: 2971K (33%)
[null] WARN (org.ecoinformatics.seek.ecogrid.SearchRegistryAction:queryRegistryRewriteConfig:201) Problem looking up registry entries using endpoint:
[null] http://knb.ecoinformatics.org/registry/services/RegistryService
[null] Invalid memory access of location 00000000 eip=90a594a8
Exception in thread "main" Java returned: 138
at org.kepler.build.modules.ModulesTask.execute(ModulesTask.java:88)
at org.kepler.build.runner.Kepler.main(Kepler.java:68)
Caused by: Java returned: 138
at org.apache.tools.ant.taskdefs.Java.execute(Java.java:108)
at org.kepler.build.Run.runSuite(Run.java:189)
at org.kepler.build.Run.run(Run.java:145)
at org.kepler.build.modules.ModulesTask.execute(ModulesTask.java:84)
... 1 more
--
Nested Exception ---
Java returned: 138
at org.apache.tools.ant.taskdefs.Java.execute(Java.java:108)
at org.kepler.build.Run.runSuite(Run.java:189)
at org.kepler.build.Run.run(Run.java:145)
at org.kepler.build.modules.ModulesTask.execute(ModulesTask.java:84)
at org.kepler.build.runner.Kepler.main(Kepler.java:68)
berkley@Slickrock kepler$

History

#1 Updated by ben leinfelder over 10 years ago

reverting to an older org.ecoinformatics.ecogrid.RegistryService-stub.jar version did not work (still had the same error)

#2 Updated by ben leinfelder over 10 years ago

removing the call to the EcogridService does not fix the invalid memory error. This doesn't have to do with that service/jar - it's a much "larger" issue.
We've got a few layers here: java calling ant that calls java...
any ideas on where to begin?

#3 Updated by ben leinfelder over 10 years ago

This same error occurs when we use the "run-workflow" ant target:
$> ant run-workflow -Dworkflow=../common/demos/getting-started/04-HelloWorld.xml

run-workflow:
[run] args: -runwf /Users/leinfelder/workspace_kepler/kepler/build-area/../common/demos/getting-started/04-HelloWorld.xml
[run] 286 ms. Memory: 9780K Free: 3942K (40%)
[run] WARN (org.ecoinformatics.seek.ecogrid.SearchRegistryAction:queryRegistryRewriteConfig:201) Problem looking up registry entries using endpoint:
[run] http://knb.ecoinformatics.org/registry/services/RegistryService
[run] Invalid memory access of location 00000000 eip=91af94a8

#4 Updated by ben leinfelder over 10 years ago

re-assigning to David - maybe he can shed some light on what might be happening.
(Unfortunately it seems like it might be isolated to Macs?)

#5 Updated by David Welker about 10 years ago

Does kepler.sh even exist anymore? I am not finding it in any of the modules I have downloaded. I cannot reproduce this problem using the 'ant run-workflow' command anymore, although I did used to get this error intermittently. Unless someone confirms that this error is still occurring for them, I am going to close this bug shortly.

#6 Updated by Chad Berkley about 10 years ago

Run the 'ant starupt-script' command to build the kepler.sh file. Not sure if this is still a bug with the new script or not.

#7 Updated by David Welker about 10 years ago

This bug is no longer occurring on the Mac with either kepler.sh or with 'ant run-workflow.' However, kepler.sh does throw an exception when you choose to exit using ctrl-c, and that is not aesthetically pleasing. However, this bug no longer exists. I am closing it.

#8 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 4034

Also available in: Atom PDF