Project

General

Profile

Bug #4053

deleting open composite actor may delete model

Added by Daniel Crawl about 10 years ago. Updated about 10 years ago.

Status:
Resolved
Priority:
Normal
Category:
interface
Target version:
Start date:
05/04/2009
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
4053

Description

Under certain circumstances, deleting an open composite actor may result in deleting the remainder of the model. Here are steps to reproduce this:

1. start kepler
2. add some actors to canvas
3. add a composite actor to canvas
4. file->save
5. open composite actor (so that a new window displays its contents)
6. without closing composite actor window, go back to top level canvas, and delete the composite actor
7. in the top level window, file->save
8. close composite actor window. the dialog to save changes will pop up; select save. (note the file is the same as the top level file name in step 4).
9. now close top level canvas

When you re-open the model, the top level contents are replaced by the empty contents of the composite actor.

I would guess that step 6 should close the composite actor's window, so that step 8 is not possible.

History

#1 Updated by Christopher Brooks about 10 years ago

This is reproducible in Ptolemy.
The issue is that if a model has a composite and the composite is open,
what happens when the composite is deleted.

#2 Updated by Christopher Brooks about 10 years ago

This is fixed by changes to PtolemyFrame.

#3 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 4053

Also available in: Atom PDF