Project

General

Profile

Bug #4171

dragging actor to canvas then back to component tree area gives NPE

Added by Derik Barseghian over 10 years ago. Updated almost 10 years ago.

Status:
Resolved
Priority:
Normal
Category:
interface
Target version:
Start date:
06/18/2009
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
4171

Description

I'm getting an NPE when I drag a component out to canvas, don't drop, and then drag it back over the component tree area:

Exception in thread "AWT-EventQueue-0" java.lang.NullPointerException
at java.awt.dnd.DropTarget$DropTargetAutoScroller.updateRegion(DropTarget.java:668)
at java.awt.dnd.DropTarget$DropTargetAutoScroller.actionPerformed(DropTarget.java:710)
at javax.swing.Timer.fireActionPerformed(Timer.java:271)
at javax.swing.Timer$DoPostEvent.run(Timer.java:201)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:461)
at java.awt.EventDispatchThread.pumpOneEventForHierarchy(EventDispatchThread.java:269)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:190)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:184)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:176)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:110)

History

#1 Updated by Christopher Brooks over 10 years ago

I can't reproduce this in Ptolemy or Kepler on the Mac under Java 1.5.0_19.
What platform and version of Java are you running?

#2 Updated by Derik Barseghian over 10 years ago

It looks like this bug is specific to the wrp suite; I don't get it in the kepler trunk or the workflow-run-manager module. Sorry about that.

I'm seeing it both on my mac: Java 1.5.0_16 and on linux: Java 1.5.0_13 when using the wrp suite.

#3 Updated by Chad Berkley over 10 years ago

I confirmed that this does not happen in the kepler suite. there might be something weird going on with the overrides in wrp or something.

#4 Updated by ben leinfelder almost 10 years ago

there's a PTree override in the reporting module...but I don't see it being referenced in that module. Looking into removing the override.

#5 Updated by ben leinfelder almost 10 years ago

removed PTree override in reporting. all better now!

#6 Updated by ben leinfelder almost 10 years ago

er, close

#7 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 4171

Also available in: Atom PDF