Project

General

Profile

Bug #419

DataPackage Wizard doesn't indicate that AttributeDomain is Required

Added by Dan Higgins over 18 years ago. Updated about 17 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
morpho - general
Target version:
Start date:
02/12/2002
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
419

Description

The current DataPackageWizard display for eml-attribute (Field Information) does
not indicate that the attributeDomain is a require element. It does show min/max
text boxes, but they are not indicated as required. Output file includes the
min/max subelements with empty text. Should have options for other
attributeDomain choices.


Related issues

Blocks Morpho - Bug #459: extend Wizard actions of TextImport WizardResolved04/06/2002

History

#1 Updated by Dan Higgins about 18 years ago

The problem here is that the 'AttributeDomain' element in eml-attribute is
really a choice of one of three types of elements: namely, an
'enumeratedDomain', a 'textDomain' or a 'numeric domain'. Unfortunately, the
current packageWizard code does not handle CHOICES; i.e there is no way to
present the wizard user with choices.

Adding the ability to handle choices will take a bit of work. It is thus being
postponed until at least 1.3

#2 Updated by Dan Higgins almost 18 years ago

Postponing for the reason previously indicated - current package wizard needs to
be reworked to handle choices.

#3 Updated by Dan Higgins about 17 years ago

This bug 'goes away' with new eml2 DataPackageWizard

#4 Updated by Redmine Admin over 7 years ago

Original Bugzilla ID was 419

Also available in: Atom PDF