Project

General

Profile

Bug #4314

exception when searching ecogrid

Added by Chad Berkley almost 10 years ago. Updated almost 10 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
data access
Target version:
Start date:
08/13/2009
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
4314

Description

When I try to search the ecogrid via kepler, I get a long exception (below). To reproduce, go to the data tab in kepler, search for "fish". You'll get an auth window. Click "login anonymously". You'll see the large exception in the console window. Kepler will take a while, but will eventually return results. Not sure what the error is about.

[run] searching..
[run] ldap authenticating...
[run] creating gui
[run] ERROR (org.ecoinformatics.seek.datasource.EcogridQueryDataCacheItem:doWork:112) The exception in query is
[run] AxisFault
[run] faultCode: {http://schemas.xmlsoap.org/soap/envelope/}Server.userException
[run] faultSubcode:
[run] faultString: java.net.ConnectException: Connection refused
[run] faultActor:
[run] faultNode:
[run] faultDetail:
[run] {http://xml.apache.org/axis/}stackTrace:java.net.ConnectException: Connection refused
[run] at java.net.PlainSocketImpl.socketConnect(Native Method)
[run] at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:333)
[run] at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:195)
[run] at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:182)
[run] at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:432)
[run] at java.net.Socket.connect(Socket.java:520)
[run] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
[run] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
[run] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
[run] at java.lang.reflect.Method.invoke(Method.java:585)
[run] at org.apache.axis.components.net.DefaultSocketFactory.create(DefaultSocketFactory.java:153)
[run] at org.apache.axis.components.net.DefaultSocketFactory.create(DefaultSocketFactory.java:120)
[run] at org.apache.axis.transport.http.HTTPSender.getSocket(HTTPSender.java:191)
[run] at org.apache.axis.transport.http.HTTPSender.writeToSocket(HTTPSender.java:404)
[run] at org.apache.axis.transport.http.HTTPSender.invoke(HTTPSender.java:138)
[run] at org.apache.axis.strategies.InvocationStrategy.visit(InvocationStrategy.java:32)
[run] at org.apache.axis.SimpleChain.doVisiting(SimpleChain.java:118)
[run] at org.apache.axis.SimpleChain.invoke(SimpleChain.java:83)
[run] at org.apache.axis.client.AxisClient.invoke(AxisClient.java:165)
[run] at org.apache.axis.client.Call.invokeEngine(Call.java:2784)
[run] at org.apache.axis.client.Call.invoke(Call.java:2767)
[run] at org.apache.axis.client.Call.invoke(Call.java:2443)
[run] at org.apache.axis.client.Call.invoke(Call.java:2366)
[run] at org.apache.axis.client.Call.invoke(Call.java:1812)
[run] at org.ecoinformatics.ecogrid.queryservice.stub.QueryServiceStub.query(Unknown Source)
[run] at org.ecoinformatics.ecogrid.queryservice.QueryServiceClient.query(Unknown Source)
[run] at org.ecoinformatics.seek.datasource.EcogridQueryDataCacheItem.doWork(EcogridQueryDataCacheItem.java:103)
[run] at org.kepler.objectmanager.cache.DataCacheObject.run(DataCacheObject.java:424)
[run] at java.lang.Thread.run(Thread.java:613)
[run]
[run] {http://xml.apache.org/axis/}hostname:Slickrock.local
[run]
[run] java.net.ConnectException: Connection refused
[run] at org.apache.axis.AxisFault.makeFault(AxisFault.java:101)
[run] at org.apache.axis.transport.http.HTTPSender.invoke(HTTPSender.java:154)
[run] at org.apache.axis.strategies.InvocationStrategy.visit(InvocationStrategy.java:32)
[run] at org.apache.axis.SimpleChain.doVisiting(SimpleChain.java:118)
[run] at org.apache.axis.SimpleChain.invoke(SimpleChain.java:83)
[run] at org.apache.axis.client.AxisClient.invoke(AxisClient.java:165)
[run] at org.apache.axis.client.Call.invokeEngine(Call.java:2784)
[run] at org.apache.axis.client.Call.invoke(Call.java:2767)
[run] at org.apache.axis.client.Call.invoke(Call.java:2443)
[run] at org.apache.axis.client.Call.invoke(Call.java:2366)
[run] at org.apache.axis.client.Call.invoke(Call.java:1812)
[run] at org.ecoinformatics.ecogrid.queryservice.stub.QueryServiceStub.query(Unknown Source)
[run] at org.ecoinformatics.ecogrid.queryservice.QueryServiceClient.query(Unknown Source)
[run] at org.ecoinformatics.seek.datasource.EcogridQueryDataCacheItem.doWork(EcogridQueryDataCacheItem.java:103)
[run] at org.kepler.objectmanager.cache.DataCacheObject.run(DataCacheObject.java:424)
[run] at java.lang.Thread.run(Thread.java:613)
[run] Caused by: java.net.ConnectException: Connection refused
[run] at java.net.PlainSocketImpl.socketConnect(Native Method)
[run] at java.net.PlainSocketImpl.doConnect(PlainSocketImpl.java:333)
[run] at java.net.PlainSocketImpl.connectToAddress(PlainSocketImpl.java:195)
[run] at java.net.PlainSocketImpl.connect(PlainSocketImpl.java:182)
[run] at java.net.SocksSocketImpl.connect(SocksSocketImpl.java:432)
[run] at java.net.Socket.connect(Socket.java:520)
[run] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
[run] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
[run] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
[run] at java.lang.reflect.Method.invoke(Method.java:585)
[run] at org.apache.axis.components.net.DefaultSocketFactory.create(DefaultSocketFactory.java:153)
[run] at org.apache.axis.components.net.DefaultSocketFactory.create(DefaultSocketFactory.java:120)
[run] at org.apache.axis.transport.http.HTTPSender.getSocket(HTTPSender.java:191)
[run] at org.apache.axis.transport.http.HTTPSender.writeToSocket(HTTPSender.java:404)
[run] at org.apache.axis.transport.http.HTTPSender.invoke(HTTPSender.java:138)
[run] ... 14 more
[run] disposing
[run] DONE disposing
[run] EcogridUtils: The time to create instance is =========== 0
[run] Authenticating with user: uid=kepler,o=unaffiliated,dc=ecoinformatics,dc=org and password: **
[run] C8071DD04D621348CF47759CC7BE3190

Related issues

Blocked by Kepler - Bug #2393: Need ability to disable 'add port' to actors where not supportedNew04/03/2006

History

#1 Updated by Chad Berkley almost 10 years ago

I also see this error when trying to access the data from one of the dragged "cans":

[run] ERROR (org.ecoinformatics.seek.dataquery.DBTablesGenerator:generateDBTextTable:481) The error in generateDBTable is Unexpected token: ? in statement [CREATE TEXT TABLE T1850755562(SpeciesOrTrophicGroup LONGVARCHAR,Code LONGVARCHAR,IndPerM]
[run] ERROR (org.ecoinformatics.seek.dataquery.DBTablesGenerator:generateDBTextTable:481) The error in generateDBTable is bad TEXT table source file - line number: 1 java.lang.NumberFormatException: For input string: "Err:503" in statement [SET TABLE T2111647632 SOURCE "urn.lsid.localdata.b441b457.0.0;fs=,"]

#2 Updated by Chad Berkley almost 10 years ago

Verify this is still happening, close this bug if not.

#3 Updated by Jing Tao almost 10 years ago

The reason is that some services, e.g. digir service and local service, are down. When I change their default value, the error message has gone.

#4 Updated by Jing Tao almost 10 years ago

The bug was fixed after removing the hosts which are down.

#5 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 4314

Also available in: Atom PDF