Project

General

Profile

Bug #4430

hsql database name and port in Kepler should be configurable

Added by jianwu jianwu about 10 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
core
Target version:
Start date:
09/30/2009
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
4430

Description

I can't start Kepler GUI when I have hadoop server running. It complains:

Caused by: java.sql.SQLException: Failed to connect to url "jdbc:hsqldb:hsql://localhost/hsqldb" as user "sa. Perhaps there was an error launching the db server. In addition, sometimes the database cache can become corrupt, so another solution is to remove the "/Users/jianwu/.kepler/cache/cachedata/hsqldb" directory.
[run] at org.kepler.util.DBConnectionFactory.getDBConnection(DBConnectionFactory.java:126)

With Dan's help, I found out it is because hadoop also have its hsql databases. Now I work it around by setting port of hsql server to another one (e.g. 9002)
1) add 'server.setPort(9002);' at launchDBServer() function.
2) change url to url = "jdbc:hsqldb:hsql://localhost:9002/" + dbName;

So I think hsql database name and port in Kepler should be configurable.

Other possible changes could be better exception handling, such as automatic port change, or mentioning this port is already in use.

History

#1 Updated by Chad Berkley almost 10 years ago

Not critical for users so moving to post 2.0.

#2 Updated by Daniel Crawl over 8 years ago

The ports and names are set in the configuration files:

common/resources/configurations/configuration.xml
core/resources/configurations/configuration.xml
provenance/resources/configurations/configuration.xml

#3 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 4430

Also available in: Atom PDF