Project

General

Profile

Bug #4517

Verify that the search capabilities work

Added by Chad Berkley about 10 years ago. Updated over 9 years ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
core
Target version:
Start date:
10/29/2009
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
4517

Description

As per the roadmap, search capability requirements include:

  • local search of direstories
  • remote search of repositories
  • search results that contain both actors and workflows
  • ability to open a workflow from the library

To close this bug, verify that the preceding functionality is operable.


Related issues

Blocks Kepler - Bug #4462: Component search in remote repositories not workingResolved10/15/2009

Blocks Kepler - Bug #4799: "Login Anonymously" gave an error during the data searchResolved02/16/2010

History

#1 Updated by Jing Tao almost 10 years ago

Except bug 4462 and 4799, the others function seems working

#2 Updated by Chad Berkley almost 10 years ago

To close this bug, close bug 4462 and bug 4799

#3 Updated by Jing Tao almost 10 years ago

Need to look at the print out on the console when we search and download data on ecogrid.

#4 Updated by Jing Tao almost 10 years ago

The debug message has gone when I tried to reproduced the issue on comment 3. I tried both kepler 2.0 and trunk. Ben verified this on kepler 2.0. So someone either turned the logging level down or changed something.

#5 Updated by Jing Tao almost 10 years ago

I saved a workflow into local repository as a kar file. The search it on the components panel. The result shows:

Workflows
- eml-simple-plot,kar
- eml-simple-plot

I tried to drag the eml-simple-plot,kar into the canvas. But I couldn't. I only can drag the second eml-simple-plot (a composite actor) to the canvas.

#6 Updated by Chad Berkley almost 10 years ago

I don't think you're supposed to be able to drag the kar to the canvas. It's just a container.

#7 Updated by Jing Tao almost 10 years ago

Chad:

What can we do to the kar search result? How can we open it?

Thanks,

Jing

#8 Updated by Chad Berkley almost 10 years ago

You should be able to drag the contents of the kar file. If the kar file doesn't have anything in it, then there is nothing to drag.

#9 Updated by Jing Tao almost 10 years ago

In this case, the kar file only has a composite actor at the result panel. Actually, I saved a workflow to the kar file. And after dragging the composite actor to the canvas, I couldn't run it.

You may reproduce the issue by saving eml-simple-plot.xml as a kar file locally. Then search it.

#10 Updated by Sean Riddle almost 10 years ago

It's probably Kepler keeping you from running a workflow without a top-level directory. Put a PN or SDF directory in the top level along with the no-port composite and try it.

#11 Updated by Jing Tao almost 10 years ago

Aaron clarify the issue:

on the search result panel, right clicking the kar entry will bring a menu. One menu item is "Open". Use this menu item, user can open the workflow.

#12 Updated by Jing Tao over 9 years ago

close the bug.

#13 Updated by Redmine Admin almost 7 years ago

Original Bugzilla ID was 4517

Also available in: Atom PDF