Project

General

Profile

Bug #4535

exception when initiating the kars of a module whose name include a period.

Added by jianwu jianwu over 9 years ago. Updated over 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
build system
Target version:
Start date:
11/05/2009
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
4535

Description

It can be reproduced by adding a 'globus3.0' in modules.txt. The exception happened when the kepler tries to initiate the kars in globus3.0 module. These kars are moved from actors module.
This exception is gone if the kars in globus3.0 module are deleted, and rebuild after clean-cache.

[run] Building Kars...
[run] Kepler Initializing...
[run] ptolemy.kernel.util.IllegalActionException: Cannot set a name with a period: Globus3.0
[run] in .<Unnamed Object>
[run] at ptolemy.kernel.util.NamedObj.setName(NamedObj.java:1917)
[run] at ptolemy.kernel.ComponentEntity.setName(ComponentEntity.java:603)
[run] at ptolemy.kernel.util.NamedObj.<init>(NamedObj.java:246)
[run] at ptolemy.kernel.util.NamedObj.<init>(NamedObj.java:215)
[run] at ptolemy.kernel.InstantiableNamedObj.<init>(InstantiableNamedObj.java:119)
[run] at ptolemy.kernel.Entity.<init>(Entity.java:135)
[run] at ptolemy.kernel.ComponentEntity.<init>(ComponentEntity.java:105)
[run] at ptolemy.kernel.CompositeEntity.<init>(CompositeEntity.java:163)
[run] at ptolemy.moml.EntityLibrary.<init>(EntityLibrary.java:202)
[run] at org.kepler.moml.FolderEntityLibrary.<init>(FolderEntityLibrary.java:44)
[run] at org.kepler.objectmanager.library.LibraryManager.addFolder(LibraryManager.java:391)
[run] at org.kepler.objectmanager.library.LibraryManager.buildFolders(LibraryManager.java:981)
[run] at org.kepler.objectmanager.library.LibraryManager.generateActorLibrary(LibraryManager.java:1165)
[run] at org.kepler.objectmanager.library.LibraryManager.getActorLibrary(LibraryManager.java:1222)
[run] at org.kepler.objectmanager.library.LibraryManager.buildLibrary(LibraryManager.java:1020)
[run] at org.kepler.objectmanager.library.LibraryManager.initialize(LibraryManager.java:1348)
[run] at org.kepler.moml.KARLibraryBuilder.buildLibrary(KARLibraryBuilder.java:75)
[run] at ptolemy.actor.gui.UserActorLibrary.openLibrary(UserActorLibrary.java:202)
[run] at ptolemy.actor.gui.UserActorLibrary.openUserLibrary(UserActorLibrary.java:140)
[run] at ptolemy.vergil.VergilApplication._createDefaultConfiguration(VergilApplication.java:322)
[run] at ptolemy.vergil.VergilApplication._createEmptyConfiguration(VergilApplication.java:339)
[run] at ptolemy.actor.gui.ConfigurationApplication._parseArgs(ConfigurationApplication.java:1116)
[run] at ptolemy.vergil.VergilApplication._parseArgs(VergilApplication.java:469)
[run] at ptolemy.actor.gui.ConfigurationApplication.<init>(ConfigurationApplication.java:226)
[run] at ptolemy.actor.gui.MoMLApplication.<init>(MoMLApplication.java:81)
[run] at ptolemy.vergil.VergilApplication.<init>(VergilApplication.java:104)
[run] at ptolemy.vergil.VergilApplication$1.run(VergilApplication.java:211)
[run] at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:209)
[run] at java.awt.EventQueue.dispatchEvent(EventQueue.java:633)
[run] at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:296)
[run] at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:211)
[run] at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:201)
[run] at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:196)
[run] at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:188)
[run] at java.awt.EventDispatchThread.run(EventDispatchThread.java:122)
[run] * Attempting to get ResourceBundle for SVG defaults
[run]
svgRenderingMethod = SVG_BATIK_RENDERING *

History

#1 Updated by Chad Berkley over 9 years ago

I am unable to reproduce this bug. This code has changed substantially since this bug was entered. I'm closing it now. reopen if necessary.

#2 Updated by Redmine Admin about 6 years ago

Original Bugzilla ID was 4535

Also available in: Atom PDF