Project

General

Profile

Bug #4570

dangling file handle for KARs

Added by Oliver Soong over 9 years ago. Updated about 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
general
Target version:
Start date:
11/20/2009
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
4570

Description

I'm not a 100% certain this is the cause, but on Windows, if I open a KAR file then close it, Kepler doesn't seem to release the file handle, which prevents me from deleting the KAR. I seem to recall having problems overwriting KAR files in the past, so this is somewhat problematic. Obviously, closing Kepler releases the file handle.

History

#1 Updated by Oliver Soong over 9 years ago

Ben said to do this.

#2 Updated by Aaron Aaron about 9 years ago

Fixed now, just needed to call the close() method on the KARFile after opening it.

#3 Updated by Redmine Admin about 6 years ago

Original Bugzilla ID was 4570

Also available in: Atom PDF