Project

General

Profile

Bug #461

Data Viewer window renders tabb seperated files incorrectly

Added by Chris Jones almost 18 years ago. Updated almost 18 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
obsolete - mde
Target version:
Start date:
04/07/2002
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
461

Description

When you create a new data package that includes a data file that is TAB
delimited, the ascii import works well, and the copy of the data file sitting in
the user's local profile data store is identical to the original. However, when
it's viewed by pressing the 'View Data' button within the editor, the
spreadsheet viewer incorrectly renders lines with missing values. It actually
just shifts cell values to the left if there are missing values to the left:

a <TAB> 1 <TAB> x
b <TAB> 2 <TAB> y
c <TAB> <TAB> z
A <TAB> 4 <TAB> X
<TAB> 5 <TAB> Y
C <TAB> 6 <TAB> Z

gets rendered as:

a 1 x
b 2 y
c z
A 4 X
5 Y
C 6 Z

History

#1 Updated by Dan Higgins almost 18 years ago

bug was caused by the presence of consequtive delimiters. Changed code that
pulled column data out of strings to be idenitical with that used in
TextImpotWizard which already handled consecqutive delimiters properly.

#2 Updated by Redmine Admin almost 7 years ago

Original Bugzilla ID was 461

Also available in: Atom PDF