Project

General

Profile

Bug #4625

authenticate against KNB, switch source to DEV, and still have access

Added by Oliver Soong over 9 years ago. Updated over 6 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
morpho - general
Target version:
Start date:
12/10/2009
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
4625

Description

I have packages that exist on DEV but not KNB. I start Morpho r4682 with KNB set as the metacat source and authenticate. I can confirm my packages are not on KNB. I then switch the metacat source to dev and open the package list and can see my packages. I can export the packages and extract the data. There was no re-authentication.

History

#1 Updated by Oliver Soong over 9 years ago

This might not be a morpho bug, now that I think about it. Maybe this should go against metacat and its authentication?

#2 Updated by ben leinfelder over 9 years ago

are the packages saved locally? then they'll show up no matter what source is used.

#3 Updated by Oliver Soong over 9 years ago

I thought about that, so I temporarily wiped my .morpho folder, but it didn't make a difference.

#4 Updated by ben leinfelder over 9 years ago

what are some of the docids you are talking about: bot h for DEV and KNB?

#5 Updated by Oliver Soong over 9 years ago

soong.28.5 should be on DEV but not KNB. The data tables in it should only be accessible by kruger-tpc and jing. Search for soong.

#6 Updated by ben leinfelder over 6 years ago

Morpho is switching to certificate-based authentication and will not be tied to any particular Member Node (Metacat) by a 'session'. While the behavior described here is unfortunate (if replicable) I think we can, in good faith, mark it as 'won't fix' because we fully expect to keep someone "logged in" even if they change to use a different MN.

#7 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 4625

Also available in: Atom PDF