Project

General

Profile

Bug #4633

LSID conflicts

Added by Oliver Soong over 9 years ago. Updated over 9 years ago.

Status:
Resolved
Priority:
Immediate
Assignee:
Category:
general
Target version:
Start date:
12/14/2009
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
4633

Description

Create a workflow and save a KAR (KAR1). Note the LSID. Change the workflow in some recognizable fashion and save a KAR (KAR2). The LSID bumps as expected. Close the workflow and open KAR1. Make a different change (so it's obviously not the workflow in KAR2) and save the KAR (KAR3). Notice that when the workflow reopens, it looks like KAR2 because it is KAR2 down to the MOML in KAR3.

I'm observing this at r22183 right now.

History

#1 Updated by Aaron Aaron over 9 years ago

Fixed, lsid updating now recognizes if it is the highest revision in the cache or not. If it isn't then it becomes one higher than the highest revision in the cache.

#2 Updated by Oliver Soong over 9 years ago

This still seems to occur if I'm not using local repositories.

The crux of the problem is nobody is tracking used revision numbers, as seems to occur with object and instance numbers.

#3 Updated by Aaron Aaron over 9 years ago

LSIDGeneration and LSID Revision updates are now being recorded. The LSID_GENERATOR table still needs to be moved to the Persistent database when that gets set up. For now the Object IDs and Revisions will come and go as you clean your cache. More logic is needed for recognizing a clean LSID_GENERATOR table and refreshing the AuthNamespace if the table is empty.

soong you're a harsh mistress, hopefully this change doesn't effect performance too terribly!

#4 Updated by Aaron Aaron over 9 years ago

The logic for querying a new namespace from an Authority in the event that the recorded object IDs and revisions have somehow been lost (deleted most likely, or table data corruption) is now in place. Just need to get the LSID_GENERATOR table into the persistent database and we can close this.

#5 Updated by Aaron Aaron over 9 years ago

Closing this bug. Opening a new bug (bug 4701) with the one remaining task of moving the LSID_GENERATOR table.

#6 Updated by Redmine Admin about 6 years ago

Original Bugzilla ID was 4633

Also available in: Atom PDF