Project

General

Profile

Bug #4636

Morpho should ignore commas inside double-quoted fields (CSV import)

Added by Jim Regetz over 9 years ago. Updated over 8 years ago.

Status:
Resolved
Priority:
Normal
Category:
morpho - general
Target version:
Start date:
12/15/2009
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
4636

Description

It is a standard CSV convention to enclose fields containing commas (i.e., commas that do not represent delimiters) in double quotes. Most applications respect this convention. However, when importing or displaying a comma-separated data file, Morpho treats all commas as field separators regardless of double quotes. This means the automatic import wizard doesn't behave properly, and data are misaligned in the data panel viewer.

A workaround is to convert the CSV file to another format (e.g., tab-delimited) before importing, but this is not always convenient nor desirable.

Sample CSV file attached.

comma_test.csv (37 Bytes) comma_test.csv Jim Regetz, 12/15/2009 02:40 PM

Related issues

Is duplicate of Morpho - Bug #5257: Incorrectly rendered column dataResolved12/15/2010

History

#2 Updated by ben leinfelder over 8 years ago

Using opencsv library (had already used it in Metacat for a different project) to parse and write data files instead of the roll-your-own approach that was in place. This is on trunk in SVN.

#3 Updated by ben leinfelder over 8 years ago

closing - please reopen with if additional problems come up.

#4 Updated by Redmine Admin about 6 years ago

Original Bugzilla ID was 4636

Also available in: Atom PDF