must support java 1.6
Metacat currently runds under java 1.5.x, which is now at end-of-life for support. We must support JDK 1.6.x in the next release, and deprecate 1.5.x. This most likely involves changes to how we handle JDBC connections, and maybe a few other issues. If you know of additional compatibility issues, please list them here.
#3 Updated by Michael Daigle almost 12 years ago
I can see arguments both ways. However, I would probably lean toward making 1.6 a requirement for a few reasons:
-- supporting 1.5 and 1.6 increases test requirements.
-- There is some functionality in 1.6 that will make the installation process smoother (specifically the file chmod functionality).
-- 1.5 is not supported.
#4 Updated by Matt Jones almost 12 years ago
I do not think we should require 1.6 at this point, as many people have existing 1.5 JVM installations on production machines, and we need to give them at least one release cycle to prepare for the change. For the KNB installs, I would want us to test extensively and have the option of falling back to a 1.5 jvm if needed during our production system upgrade. So, for the 1.9.2 release, we should support both 1.5 and 1.6, but we should clearly note that JDK 1.5 is deprecated and will not be supported in the next minor release.
To close this bug, we need to update the release notes and Admin Guide to indicate the status of JVM support.
#5 Updated by Michael Daigle almost 12 years ago
Updated release notes and Metacat Administrators Guide. Note that the pdf version of the guide does not have active internal links. Apparently, cannot be created with a mac version of acrobat pro.
If the links are needed, the pdf would have to be recreated on a windows box with acrobat pro.