Project

General

Profile

Bug #4661

table 'worksheet' display not updated after table deleted

Added by Margaret O'Brien almost 11 years ago. Updated almost 11 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
morpho - general
Target version:
Start date:
01/12/2010
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
4661

Description

a user wanted to replace a dataTable in a package. She chose 'Data->delete data table'. The data table disappeared, and she added uploaded a new table and a created a new set of attribute descriptions. So far, this is as expected.

However, when she finished the attribute descriptions, and Morpho displayed the table, it displayed the old attribute descriptions in the 'worksheet' pane. When she clicked on an attribute, the new attribute description was displayed on the right (alongside the old table). When she closed the data package and reopened, the new data table was there, so it seems to be just a worksheet display issue.

The EML docids are cdonahue.26.2 (old table, to be deleted) and cdonahue.26.3 (new table)

History

#1 Updated by Jing Tao almost 11 years ago

I can reproduce bug on current svn version morpho.

#2 Updated by Jing Tao almost 11 years ago

In AbstractDataPackage method, there is variable to cache the attribute list of selected entity. This attribute list will be used to display the attributes on worksheet. However, the cached the attribute list wasn't reset when a entity was deleted, so user will see old attribute. After adding resetting the attribute list, the bug has been fixed.

Margaret, would you please test it again through a svn version of Morpho to make sure the bug was fixed?

#3 Updated by Jing Tao almost 11 years ago

close it. If margaret finds some issue, we will reopen it.

#4 Updated by Jing Tao almost 11 years ago

Change it to fixed status.

#5 Updated by Redmine Admin over 7 years ago

Original Bugzilla ID was 4661

Also available in: Atom PDF