Project

General

Profile

Bug #4673

past runs with workflows that get renamed don't reflect this

Added by Derik Barseghian almost 10 years ago. Updated over 9 years ago.

Status:
Resolved
Priority:
Normal
Category:
workflow run manager
Target version:
Start date:
01/14/2010
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
4673

Description

If you export a run that is Unnamed1, you're prompted to give it a workflow name. If you name it, provenance renames this workflow, and all past runs should reflect the workflow name change in the Workflow Run Manager. Now that I'm keeping runs in memory, this is no longer happening until you restart kepler the runs are recreated from provenance.


Related issues

Is duplicate of Kepler - Bug #4679: Workflow Name in Workflow Run Manager is not updated when renaming workflowResolved01/19/2010

History

#2 Updated by Derik Barseghian almost 10 years ago

Ensure this procedure works as well before marking this bug fixed:

Aaron said:
Does this have something to do with the Provenance Database design? Perhaps it
can be solved by adding a Name column to the Workflow_exec table? The same way
we added lsid to the workflow_exec table. Or are we just patching up a deeper
design flaw?

To reproduce this:
Create new workflow in the wrp suite
Run the workflow
Notice in the Workflow Run Manager Panel on the Report designer the Workflow
Name is Unnamed1
Now go back to the workflow and right click on the canvas
select "Rename" from the context menu
enter a new name for the workflow in the dialog box and press OK
run the workflow again
go back to the Workflow Run Manager Panel and notice the Workflow Name field
for the new Run, It should be the new workflow name

#3 Updated by Derik Barseghian over 9 years ago

Looks like procedure in comment#2 is an additional problem -- I think provenance only renames prior runs of the same workflow if you go through the Save Kar process. If you use the new canvas "Rename" option, they don't get renamed unless you Save Kar.

#4 Updated by Derik Barseghian over 9 years ago

Correction to my last comment:
1) provenace renames past runs if you do a Save As.
2) If you do a Save Archive they only get renamed if you run it again after it's been renamed.

r22571 makes WRM refresh appropriately for 1). Case 2) yet to be fixed.

#5 Updated by Derik Barseghian over 9 years ago

The reason there's the problem in 2) is that ExportArchiveAction does not notify KeplerGraphFrameSave listeners like KeplerGraphFrame _saveAs does:

listener.savedWorkflow(model, _preSaveLSID, _postSaveLSID,effigyId);

Looking at the differences in ExportArchiveAction and KeplerGraphFrame _saveAs makes me think the two need to be better integrated.

#6 Updated by Derik Barseghian over 9 years ago

Fixed in r22607

#7 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 4673

Also available in: Atom PDF