Project

General

Profile

Bug #4679

Workflow Name in Workflow Run Manager is not updated when renaming workflow

Added by Aaron Aaron almost 10 years ago. Updated almost 10 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
provenance
Target version:
Start date:
01/19/2010
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
4679

Description

Does this have something to do with the Provenance Database design? Perhaps it can be solved by adding a Name column to the Workflow_exec table? The same way we added lsid to the workflow_exec table. Or are we just patching up a deeper design flaw?

To reproduce this:
Create new workflow in the wrp suite
Run the workflow
Notice in the Workflow Run Manager Panel on the Report designer the Workflow Name is Unnamed1
Now go back to the workflow and right click on the canvas
select "Rename" from the context menu
enter a new name for the workflow in the dialog box and press OK
run the workflow again
go back to the Workflow Run Manager Panel and notice the Workflow Name field for the new Run, It should be the new workflow name


Related issues

Has duplicate Kepler - Bug #4673: past runs with workflows that get renamed don't reflect thisResolved01/14/2010

History

#1 Updated by Derik Barseghian almost 10 years ago

dupe of 4673

#2 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 4679

Also available in: Atom PDF