Project

General

Profile

Bug #4730

Kepler cannot run workflows stored in KAR files from the command-line.

Added by Oliver Soong about 9 years ago. Updated about 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
build system
Target version:
Start date:
02/03/2010
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
4730

Description

If I run:
C:\kepler\build-area>ant run-workflow -Dworkflow="C:\Users\visitor\Desktop\kruger workflows\tpc01-buffalo-tb\tpc01-buffalo-tb.kar"

I get errors:
Unsupported file type or connection not available: file:/C:/Users/visitor/Desktop/kruger
Unsupported file type or connection not available: file:/C:/kepler/workflows/tpc01-buffalo-tb/tpc01-buffalo-tb.kar

If I run:
C:\kepler\build-area>ant run-workflow -Dworkflow="C:\Users\visitor\Desktop\kruger~1\tpc01-buffalo-tb\tpc01-buffalo-tb.kar"

I get this error:
Unsupported file type or connection not available: file:/C:/Users/visitor/Desktop/kruger%20workflows/tpc01-buffalo-tb/tpc01-buffalo-tb.kar

I'm guessing this applies to a number of other ant targets as well (most of the run-workflow ones, for example).

History

#1 Updated by ben leinfelder about 9 years ago

This is not just files with spaces in the path - I'm getting an error as well:

Unsupported file type or connection not available: file:/Users/leinfelder/workspace_kepler/kruger/workflows/tpc02-water-flow/tpc02-water-flow-base.kar

#2 Updated by David Welker about 9 years ago

This bug does not exist when running ant "run-workflow" against an ordinary workflow which is stored in an XML file. I just ran it on outreach/resources/demos/getting-started/04-HelloWorld.xml and it worked fine.

The problem here is simply that it is not possible to run workflows stored in kar files from the command-line.

This brings up a related issue. It seems to me that the KAR file format is obsolete. The original purpose, as I understand it, is to allow actors or workflows to include jars and other resources they need. But, shouldn't such resources be generally provided by modules?

Perhaps the KAR format is still relevant if what we want to distribute with an actor is a special image or icon to represent that actor in Kepler that we would not expect a module to provide...

Anyway, I am renaming this bug. The problem appears to be that workflows stored in kar files cannot be executive by Kepler from the command-line. As the build merely defers this work to the command-line, if the command-line worked, so would this ant command.

#3 Updated by Chad Berkley about 9 years ago

The spaces aren't the issue. I can run this with no problem:

java -classpath build-area/lib/ant.jar:kepler.jar org.kepler.build.runner.Kepler -runwf -nogui /Users/berkley/project/kepler/outreach/resources/demos/getting-started/01\ Simple\ Addition.xml

However, I cannot run this:
ant run-workflow -Dworkflow=/Users/berkley/project/kepler/outreach/resources/demos/getting-started/01\ Simple\ Addition.xml

So the problem is in the build system runner. Also, running workflows from kars is supported. you just need the -runkar arg.

I'll figure this out and get a fix checked in asap.

#4 Updated by Chad Berkley about 9 years ago

This is actually two bugs.

Bug 1: Spaces in the paths on a workflow run does not work. I found this to be true and I fixed it.

Bug 2: -runkar does not work. This is also true. I'm working on this. it looks like the code in loader that processed the kar file might have been removed.

#5 Updated by Chad Berkley about 9 years ago

Running kars is not supported except in a server configuration. The reason for this is that the kar is first sent to a host, the workflow is extracted, then it is run. There is no kepler client side code to do this and AFAICT there never has been. If you want to run a workflow inside of a kar, you need to extract it first. Since this is not a 2.0 feature, I'm closing this bug. If this is needed, please add a new feature request for post 2.0.

I have confirmed that spaces in paths do now work for running workflows.

#6 Updated by Redmine Admin almost 6 years ago

Original Bugzilla ID was 4730

Also available in: Atom PDF