Project

General

Profile

Bug #4865

Second time running a workflow by command line faild

Added by Jing Tao about 9 years ago. Updated about 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
core
Target version:
Start date:
03/03/2010
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
4865

Description

I use the following command to run a workflow:
java -classpath build-area/lib/ant.jar:kepler.jar org.kepler.build.runner.Kepler -server -repository=chico1Repository -runwf -nogui /tmp/kar/8061.4.1.kar

under kepler directory.

The first time, it succeeded. However, when the second time it failed:
[null] Cached KAR contents
[null] Processing entry, LSID=urn:lsid:gamma.msi.ucsb.edu/OpenAuth/:8016:19:1, type=org.kepler.moml.CompositeClassEntity
[null] Command failed
[null] java.lang.Exception: Failed to parse "ptolemy/configs/kepler/ConfigNoGUIWithCache.xml -runThenExit -server -repository=chico1Repository /tmp/kar/8061.4.1.kar"
[null] at ptolemy.actor.gui.ConfigurationApplication.throwArgsException(ConfigurationApplication.java:651)
[null] at org.kepler.KeplerConfigurationApplication.<init>(KeplerConfigurationApplication.java:288)
[null] at org.kepler.KeplerConfigurationApplication.main(KeplerConfigurationApplication.java:582)
[null] at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
[null] at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
[null] at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
[null] at java.lang.reflect.Method.invoke(Method.java:585)
[null] at org.kepler.Kepler.load(Kepler.java:321)
[null] at org.kepler.Kepler.load(Kepler.java:339)
[null] at org.kepler.Kepler.parseArgsAndRun(Kepler.java:267)
[null] at org.kepler.Kepler.main(Kepler.java:169)
[null] Caused by: org.kepler.objectmanager.cache.CacheException: Exception occurred while deserializing object
[null] at org.kepler.objectmanager.cache.CacheManager.getObject(CacheManager.java:529)
[null] at org.kepler.KeplerConfigurationApplication.<init>(KeplerConfigurationApplication.java:171)
[null] ... 9 more
[null] Caused by: java.io.IOException: Error in ActorCacheObject(ReadExternal): null
[null] at org.kepler.objectmanager.cache.ActorCacheObject.readExternal(ActorCacheObject.java:250)

If I deleted the .kepler, it worked again.

History

#1 Updated by Chad Berkley about 9 years ago

I ran into this also. I think the LSID is getting put in the cache, then when you try to run the WF from the kar file again, it tries to cache the same kar but the LSID already exists so it fails. The cache needs to figure out somehow (or ignore) that the kar file is already cached.

#2 Updated by Derik Barseghian about 9 years ago

This was the problem Ben fixed the other day, but began recurring again probably because of my changes in r23263, but it should be fixed now at r23264. Jing is going to test...

#3 Updated by Derik Barseghian about 9 years ago

Working now for Jing and I, closing.

#4 Updated by Redmine Admin about 6 years ago

Original Bugzilla ID was 4865

Also available in: Atom PDF