Project

General

Profile

Bug #4910

Test module installation system

Added by debi staggs about 9 years ago. Updated about 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
core
Target version:
Start date:
03/29/2010
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
4910

Description

Test module installation system.

History

#1 Updated by debi staggs about 9 years ago

I have implemented this solution now. A user can 'lock' the report layout if they haven't run or saved yet, so that if they click on the rows in the workflow run manager, they won't lose their changes accidentally. Also added a feature that warns them if they have not locked their report + the ability to turn that warning dialog off.

#2 Updated by debi staggs about 9 years ago

Accidentally closed this bug, please disregard the last comment as it was intended for a bug # 4923.

#3 Updated by Chad Berkley about 9 years ago

Module Manager is now working with http. Tested the switching between suites and it seems to be working well. Need verification from third party.

#4 Updated by debi staggs about 9 years ago

Module system testing confirms that it is working well, and in the process of testing we also decided to make a few simple changes to the GUI, which will be entered as a separate bug. Also, it appears that some changes have been made recently to the PatchChecker class so I am leaving this bug open until David and Chad can confirm that there are no further additions / updates still pending.

#5 Updated by Christopher Brooks about 9 years ago

Is the module installation system tested when I run "ant test" and as part
of the nightly build?

#6 Updated by debi staggs about 9 years ago

I think that this has been resolved. So closing for now, unless there are any objections.

#7 Updated by Redmine Admin about 6 years ago

Original Bugzilla ID was 4910

Also available in: Atom PDF