Project

General

Profile

Bug #4975

Morpho can't handle docid prefix containing a period

Added by Jim Regetz over 9 years ago. Updated over 9 years ago.

Status:
Resolved
Priority:
Normal
Category:
morpho - general
Target version:
Start date:
05/04/2010
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
4975

Description

A user just reported mysterious problems attempting to save and reopen documents in Morpho. It appears the problem is that her prefix contains a period, impairing Morpho's ability to parse the document id.

Steps to reproduce:
  • Create a new profile, choosing a prefix that contains a period (foo.bar)
  • Create a new data package, and save locally
  • Restart Morpho

The saved package doesn't appear in the Open Data Package window.

Also, .morpho/profiles/foo.bar/data looks like this:
`-- foo
`-- bar.3.1

Rather than this:
`-- foo.bar
`-- 3.1

Either Morpho needs to be smarter about parsing IDs, or if such a prefix is illegal, it shouldn't allow users to create one containing periods in the first place (and this should be documented).

History

#1 Updated by ben leinfelder over 9 years ago

I'm pretty sure this has come up before. We're already preventing the use of "temporary" as a prefix. I believe Metacat does not allow periods in the docid scope as well.

#2 Updated by ben leinfelder over 9 years ago

periods not allowed anymore.
help/error text indicates such.

#3 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 4975

Also available in: Atom PDF