Project

General

Profile

Bug #5011

Add support for DataONE service API

Added by Matt Jones over 9 years ago. Updated over 6 years ago.

Status:
Resolved
Priority:
Immediate
Category:
metacat
Target version:
Start date:
05/14/2010
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
5011

Description

Metacat will be used within DataONE as both a Member Node and as a component of the Coordinating Node infrastructure. We need to add support for the proper REST APIs for DataONE, which are described here:

http://mule1.dataone.org/ArchitectureDocs/index.html

Initial support should include the following methods:
MN.get()
MN.getSystemMetadata()
MN.listObjects()

CN.create()
CN.update()
CN.get()
CN.getSystemMetadata()
CN.resolve()

These tasks are a DataONE project, and so details are being tracked in the DataONE ticket system (http://trac.dataone.org). This is a tracking bug for the feature overall.


Related issues

Is duplicate of Metacat - Bug #5514: implement DataONE service APIResolved10/26/2011

History

#2 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 5011

Also available in: Atom PDF