Project

General

Profile

Bug #5049

Prompt for credentials when connecting to remote kepler server

Added by Derik Barseghian almost 9 years ago. Updated about 8 years ago.

Status:
Resolved
Priority:
Normal
Category:
sensor-view
Target version:
Start date:
06/15/2010
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
5049

Description

At some point in Figure 6( https://kepler-project.org/developers/incubation/kepler-engineering-view-for-reap/engineering-view-plans ), the user should be prompted for credentials to be able to connect to and view the remote runs of a workflow in the workflow run manager. I'm not sure yet when and how this should work. We need to consider credentials for the scheduler and the provenance store.


Related issues

Is duplicate of Kepler - Bug #5132: Connecting Workflow Run Manager to remote KAR store should prompt for credentialsResolved08/06/2010

Blocked by Kepler - Bug #5032: Workflow Run Manager - ability to connect to different prov stores from gui actionsResolved05/27/2010

Blocks Kepler - Bug #5062: create bugs, mockups, eng view page updates showing how authentication will workResolved06/28/2010

History

#1 Updated by Derik Barseghian almost 9 years ago

Add new tab in Preferences for configuring remote stores.

#2 Updated by Derik Barseghian over 8 years ago

This new tab is no longer relevant, we've decided to use the existing Components servers as remote stores.

(In reply to comment #1)

Add new tab in Preferences for configuring remote stores.

#4 Updated by Derik Barseghian about 8 years ago

Prompting for credentials when connecting a WRM to a remote kar-store happens now, if the user has selected the 'authenticate' checkbox.
However I'm still not sure I'm happy with the gui, I'm going to ask others for feedback.

#5 Updated by Derik Barseghian about 8 years ago

I removed the authenticate checkbox at r26873. Now like Component search you're just prompted to login (if you're not already) the first time you choose a remote repository from WRM.

#6 Updated by Derik Barseghian about 8 years ago

changing bugs from REAP to Kepler product

#7 Updated by Redmine Admin about 6 years ago

Original Bugzilla ID was 5049

Also available in: Atom PDF