Project

General

Profile

Actions

Bug #5132

closed

Connecting Workflow Run Manager to remote KAR store should prompt for credentials

Added by Jing Tao over 12 years ago. Updated almost 12 years ago.

Status:
Resolved
Priority:
Normal
Category:
sensor-view
Target version:
Start date:
08/06/2010
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
5132

Description

We need an authentication and authorization mechanism for client kepler to access remote Provenance DB.

We can borrow the existing Scheduler Server mechanism:
String isLoggedIn(String sessionid)
boolean isAuthorized(String user)

Here are some open questions:

1. What format do we specify access rule? By an eml access file?
2. If we use eml access rule, what level will be used as data object? The whole database or each run result?
3. How can we specify the access rule? Maybe we need another GUI for this. Where should we put it?


Related issues

Has duplicate Kepler - Bug #5049: Prompt for credentials when connecting to remote kepler serverResolvedDerik Barseghian06/15/2010

Actions
Actions #1

Updated by Jing Tao over 12 years ago

In our reap meeting, we decided to import remote workflow run kar files rather than directly access a remote provenance DB for the display of the remote workflow run manager . So I think we can close the bug. But this need a confirmation from Derik.

Actions #2

Updated by Derik Barseghian about 12 years ago

Just discussed this bug with Dan - it's true most of the original intent of this bug is no longer relevant now that I'll download kars for showing remote runs, but I'm changing the title and leaving it open -- when you connect to a remote kar-repository with the WRM, you should be prompted for credentials so you can view private run-kars too, similar to how data tab searches prompt you on your first search.

Actions #3

Updated by Derik Barseghian almost 12 years ago

Marking duplicate of bug#5049

Actions #4

Updated by Derik Barseghian almost 12 years ago

changing bugs from REAP to Kepler product

Actions #5

Updated by Redmine Admin almost 10 years ago

Original Bugzilla ID was 5132

Actions

Also available in: Atom PDF