Project

General

Profile

Bug #5080

Cannot save updated Data Package version to Network, despite full access permissions

Added by Rick Reeves over 10 years ago. Updated over 10 years ago.

Status:
Resolved
Priority:
Normal
Category:
morpho - query
Target version:
Start date:
07/06/2010
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
5080

Description

Running Morpho 1.8 under Windows 7/64, I am importing and documenting a new .csv table to an existing data package knb.247.6 saved locally on my system.
I am logged in as (Carlos) Melian, the originator of this package. Carlos'
account has full access rights to the
When I try to save the data package (with new documentation) to the network,
Morpho displays the following error message (also see attached screenshot):

"Problem with saving to Metacat in EML200DataPackage"
<error> User tried to update an access module with they dont have "ALL" permission!</error>

In fact, as logged in (as Carlos), I do have ALL permission.

I need to be able to save this package to Metacat, need to get this resolved.

Thanks, Rick R

History

#1 Updated by ben leinfelder over 10 years ago

The permissions look to be fine in both the EML and in the DB (both data and metadata are owned by 'uid=melian,o=NCEAS,dc=ecoinformatics,dc=org'
If you are indeed logged in as that user, you shouldn't even need to have explicit permissions defined for that user since it 'owns' the documents.
What does the local data package look like?

#2 Updated by ben leinfelder over 10 years ago

One idea for isolating the problem:
-get the version as it exists on the server (knb.247.5)
-make a simple edit (say to the title)
-save to metacat
If that works, then you can try adding a data table...and try the save again.

#3 Updated by ben leinfelder over 10 years ago

Starting from the clean network version:
-saved a copy locally
-did a minimal metadata edit
-saved to the network again
Worked.
Unfortunately this package (knb.247) was deleted soon after. On the brightside, a duplicate of the package still existed and was saved to the network. A mock data file was attached and had different permissions set on it. This too worked (see melian.8.x).
Not sure what the glitch was with knb.247, but will have to wait for it to crop up again before tracking it down more.

#4 Updated by Redmine Admin over 7 years ago

Original Bugzilla ID was 5080

Also available in: Atom PDF