Project

General

Profile

Bug #5160

problem changing suites using Module Manager

Added by Derik Barseghian almost 9 years ago. Updated almost 9 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
interface
Target version:
Start date:
08/24/2010
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
5160

Description

In the test releases area, I've published all 2.1.0 modules.
If I launch kepler (configured to look at the test-area) and use the Module Manager to change to reporting-2.1.0, and restart, reporting comes up (good). If I then attempt to use the MM to change to workflow-run-manager-2.1.0, and restart, reporting again comes up, not wrm, and 'ant list-modules' shows it still in the list:
------------
list-modules:
[list-modules] reporting-2.1.0
[list-modules] workflow-run-manager-2.1.0
[list-modules] provenance-2.1.0
...etc...
------------
The contents of wrm's modules.txt is:
*provenance-2.1.^

If I then use the MM to change to provenance-2.1.0, wrm comes up. If I then use MM to change to provenance again, wrm still comes up.

History

#1 Updated by David Welker almost 9 years ago

I am unable to reproduce this problem. In fact, I was able to change from reporting-2.1.0 to workflow-run-manager-2.1.0 and back successfully. I suspect the issue is that the 2.1 modules that Derik is using do not incorporate all of the recent changes that have been made. I will discuss this more with Derik before closing this bug.

#2 Updated by Derik Barseghian almost 9 years ago

The problem was that Module Manager's AvailableModulesPanel was deleting the new current-suite.txt file, but not rewriting a new one with the string "unknown", which is apparently necessary. David checked in a fix at r25511, and i've merged this into 2.1 w/ r25512. I've also republished module-manager-gui to include the fix, and changing between suites seems to be working now. Closing.

#3 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 5160

Also available in: Atom PDF