Project

General

Profile

Bug #5341

Belkin f5u409 usb=>serial dongle periodically stops working

Added by Derik Barseghian over 8 years ago. Updated almost 7 years ago.

Status:
New
Priority:
Normal
Category:
sensor-view
Target version:
Start date:
03/04/2011
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
5341

Description

Sometimes the Belkin dongle gets in a state where all 3 of its LEDs stay off. This corresponds with being unable to run cr1k_d over it. I'm not sure if this is the sole reason for bug#5332, or if that sometimes happens even when the lights are on.

When this state occurs, and you try to use cr1k_d, dmesg starts showing errors like:

usb 1-1: cr1k_d timed out on ep0out len=0/1
usb 1-1: Set MODEM CTRL 0xb failed (error = -110)
usb 1-1: cr1k_d timed out on ep0out len=0/1
usb 1-1: Set LINE CTRL 0x3 failed (error = -110)
usb 1-1: cr1k_d timed out on ep0in len=0/1
usb 1-1: Get MODEM STATus failed (error = -110)
usb 1-1: cr1k_d timed out on ep0out len=0/1

I've tried this procedure to see if I could get the dongle working again, but it didn't work:
lsmod | grep -i usb
sudo rmmod mct_u232;
lsmod | grep -i usb;
sudo modprobe mct_u232

Rebooting consistently makes it work again.

Nick recommends trying a Keyspan dongle, and updating from ubuntu 9.04 to 10.04 (new kernel, possible hardware fixes).
I'll try the dongle he recommends when I get a chance.


Related issues

Blocked by Kepler - Bug #5332: cr1k_d doesn't reliably connect to loggerResolved03/01/2011

History

#1 Updated by Derik Barseghian over 8 years ago

I tried a ("the purple one") prolific pl2303 usb-serial dongle on the gumstix. Ubuntu recognized the dongle, but I was unable to connect. However I'm currently unable to connect with the Belkin as well (even after reboot), so I don't know what's to blame.

#2 Updated by Derik Barseghian about 8 years ago

Unfortunately my Belkin dongle can still "die" (I restart ubuntu to get it working again)- it happened again last friday. I don't think this has happened a single time to Dan, and he's using the exact same dongle.
I'm now testing my purple prolific dongle. It's working at the moment.

#3 Updated by Derik Barseghian about 8 years ago

The prolific dongle dies too, in a similar fashion - at a certain point dmesg shows errors and you can no longer use it without a system restart. I tried simply reloading the pl2303 and usbserial modules, but no luck, lsusb -v will still include an error for the dongle:
cannot read device status, Connection timed out (110)

dmesg:
------
usb 1-1: cr1k_d timed out on ep0out len=0/0
usb 1-1: cr1k_d timed out on ep0out len=0/0
usb 1-1: cr1k_d timed out on ep0in len=0/7

and later:

usb 1-1: lsusb timed out on ep0in len=0/255
usb 1-1: usbfs: USBDEVFS_CONTROL failed cmd lsusb rqt 128 rq 6 len 255 ret 110
-----

Now I've changed:
/sys/bus/usb/devices/usb1/power/level (MUSB HDRC host driver)
/sys/bus/usb/devices/usb2/power/level (OMAP-EHCI Host Controller)

from auto to on, to disable autosuspend, in case something has a problem resuming after suspension.

/sys/bus/usb/devices/1-1/power/level (the USB-Serial Controller) was already on.
Let's see if this helps.

Other things yet to try: a keyspan dongle, ubuntu upgrade, connecting dongle through a powered usb hub (though this wouldn't be ideal).

#4 Updated by Derik Barseghian about 8 years ago

Didn't help, dongle became unresponsive as usual (also note that power levels change back to auto on reboot). Going to buy a keyspan from radioshack.
(In reply to comment #3)

#5 Updated by Derik Barseghian about 8 years ago

The local radioshack actually doesn't carry the keyspan, so I got one off amazon. Ubuntu recognizes it, but SPAN won't start up with it, and minicom actually locks up when trying to initialize using default settings, in both ubuntu 10.04 (desktop) and 9.04 (gumstix). I can get minicom to not lock up if I turn off Hardware Flow Control. This is where I left off messing around with the keyspan.

I setup span on my 10.04 desktop, and using the belkin i let it run, sampling each sensor at 1sps, over the weekend and it survived. Unfortunately to do other work I had to stop this run, so it's not conclusive the belkin won't die on the desktop-- I'd want a run to last ~ >5 days to believe that, but it seems very possible (typically the belkin on the gumstix would die at about a day or so, but it has lasted longer).
I'm still a little suspicious of usb power settings on the gumstix, or worse maybe something physical related to the OTG port + adapter + dongle.
Afaik Dan's long-run continues to work without problem on his gumstix w/ belkin, however I recall he has a different version of the Tobi board...

#6 Updated by Derik Barseghian about 7 years ago

Just another datapoint: I've been using my Keyspan without problem on my mac 10.6 running SPAN. I believe I let it run over night once.

Lowering 'importance', we may not be able to give an adapter recommendation for the initial release.

#7 Updated by Derik Barseghian almost 7 years ago

Moving to 1.x.y target.

#8 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 5341

Also available in: Atom PDF