Project

General

Profile

Bug #5448

cannot start Kepler using non-IcedTea OpenJDK

Added by Daniel Crawl almost 8 years ago. Updated almost 7 years ago.

Status:
Resolved
Priority:
Normal
Category:
general
Target version:
Start date:
08/04/2011
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
5448

Description

Christopher Brooks reports:

Under RedHat, I was able to run Kepler-2.2.0 under Sun JDK 1.6.0_21

However, as expected, OpenJDK 1.6.0 fails

bash-3.2$ java version
java version "1.6.0"
OpenJDK Runtime Environment (build 1.6.0-b09)
OpenJDK 64-Bit Server VM (build 1.6.0-b09, mixed mode)
bash-3.2$ ./kepler.sh
JVM Memory = 5m 512m
[null] Checking for patches...
[null] Building Kars...
[null] Ran additional initialization for module core from class
org.kepler.module.core.Initialize
[null] Ran additional initialization for module gui from class
org.kepler.module.gui.Initialize
[null] X connection to localhost:10.0 broken (explicit kill or server
shutdown).
Exception in thread "main" Java returned: 1
at org.kepler.build.modules.ModulesTask.execute(ModulesTask.java:106)
at org.kepler.build.runner.Kepler.main(Kepler.java:94)
Caused by: Java returned: 1
at org.kepler.build.modules.ModulesTask.execute(ModulesTask.java:106)
at org.kepler.build.runner.Kepler.run(Kepler.java:218)
at org.kepler.build.modules.ModulesTask.execute(ModulesTask.java:102)
... 1 more
Caused by: Java returned: 1
at org.apache.tools.ant.taskdefs.Java.execute(Java.java:108)
at org.kepler.build.Run.runSuite(Run.java:309)
at org.kepler.build.Run.run(Run.java:213)
at org.kepler.build.modules.ModulesTask.execute(ModulesTask.java:102)
... 3 more
--
Nested Exception ---
Java returned: 1
at org.kepler.build.modules.ModulesTask.execute(ModulesTask.java:106)
at org.kepler.build.runner.Kepler.run(Kepler.java:218)
at org.kepler.build.modules.ModulesTask.execute(ModulesTask.java:102)
at org.kepler.build.runner.Kepler.main(Kepler.java:94)
Caused by: Java returned: 1
at org.apache.tools.ant.taskdefs.Java.execute(Java.java:108)
at org.kepler.build.Run.runSuite(Run.java:309)
at org.kepler.build.Run.run(Run.java:213)
at org.kepler.build.modules.ModulesTask.execute(ModulesTask.java:102)
... 3 more
--- Nested Exception ---
Java returned: 1
at org.apache.tools.ant.taskdefs.Java.execute(Java.java:108)
at org.kepler.build.Run.runSuite(Run.java:309)
at org.kepler.build.Run.run(Run.java:213)
at org.kepler.build.modules.ModulesTask.execute(ModulesTask.java:102)
at org.kepler.build.runner.Kepler.run(Kepler.java:218)
at org.kepler.build.modules.ModulesTask.execute(ModulesTask.java:102)
at org.kepler.build.runner.Kepler.main(Kepler.java:94)
bash-3.2$

It is unfortunate that command that was executed is not returned, nor is the
error message.

Ptolemy II, when run outside of Kepler, starts up fine with OpenJDK . . .

On sisyphus.eecs.berkeley.edu, we are running:

[bldmastr@sisyphus test]$ rpm -qa redhat-release
redhat-release-5Client-5.4.0.3
[bldmastr@sisyphus test]$ cat /etc/redhat-release
Red Hat Enterprise Linux Client release 5.4 (Tikanga)

History

#1 Updated by Christopher Brooks almost 7 years ago

Fixed in Kepler 2.3 and in the Kepler devel trunk

bash-3.2$ java -version
java version "1.6.0_22"
OpenJDK Runtime Environment (IcedTea6 1.10.6) (rhel-1.25.1.10.6.el5_8-x86_64)
OpenJDK 64-Bit Server VM (build 20.0-b11, mixed mode)
bash-3.2$ which java
/usr/java/java-1.6.0-openjdk.x86_64/bin/java

Works!

#2 Updated by Redmine Admin about 6 years ago

Original Bugzilla ID was 5448

Also available in: Atom PDF