Project

General

Profile

Bug #5461

Add a directory to contain all modules in linux installer

Added by Jing Tao almost 8 years ago. Updated almost 8 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
build system
Target version:
Start date:
08/15/2011
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
5461

Description

In the current linux installer, the modules will be decompressed to the directory where you run the command. So I have to manually to create a directory named kepler-2.3-rc1 to contain all modules in order to manage the installation easily.

Can we add directory kepler-2.3-rc1 (or kepler-2.3) above the moduels in the installer? So people don't need to manually added a directory.

Current the structure looks like:
build-area/current-suite.txt
build-area/install-id.txt
build-area/lib/ant.jar
.......

kepler.jar
kepler.sh
.....
kepler-2.3.0/resources/system.properties/
kepler-2.3.0/module-info/licenses.txt
kepler-2.3.0/module-info/modules.txt
........

We may change to :

kepler-2.3/build-area/current-suite.txt
kepler-2.3/build-area/install-id.txt
kepler-2.3/build-area/lib/ant.jar
.......

kepler-2.3/kepler.jar
kepler-2.3/kepler.sh
.....
kepler-2.3/kepler-2.3.0/resources/system.properties/
kepler-2.3/kepler-2.3.0/module-info/licenses.txt
kepler-2.3/kepler-2.3.0/module-info/modules.txt
........


Related issues

Is duplicate of Kepler - Bug #5445: Kepler 2.2.0 tar file should create a kepler-2.2.0 directoryResolved07/31/2011

History

#2 Updated by Derik Barseghian almost 8 years ago

fixed at 28343-28345

#3 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 5461

Also available in: Atom PDF