Project

General

Profile

Bug #5473

2.3.0rc1 won't start on Windows XP

Added by Derik Barseghian almost 8 years ago. Updated over 7 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
installer
Target version:
Start date:
08/16/2011
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
5473

Description

I can't get 2.3.0 rc1 to start on Windows XP after installing using the installer.
The shortcuts are broken, and double-clicking on kepler.exe and module-manager.exe doesn't do anything.

History

#1 Updated by Derik Barseghian over 7 years ago

This is caused by the existence of the file use.keplerdata, e.g. C:\Program Files\Kepler-2.3\build-area\use.keplerdata .

It looks like use.keplerdata is currently always created and included in the installers. I don't know why. I thought KeplerData\kepler.modules was only supposed to be used as a place to download modules when a user doesn't have permission to download into the kepler application folder.

I also see that KeplerData\kepler.modules\build-area contains files like install-id.txt, modules.txt, current-suite.txt. If these are not modified by the build-system, the module manager, and during installation of a new kepler, it seems like we will have problems like bug#5458.

David, can you clarify when KeplerData\kepler.modules is supposed to be used?

#2 Updated by David Welker over 7 years ago

Hi Derik,

This directory, as you suggest, is only for downloaded modules. The build system first looks relative to itself, and only if it doesn't find the module does it look in KeplerData/kepler.modules.

However, this folder is typically used regardless of whether the user has permissions or not. The system does not differ in where downloads occur due to permissions.

I am not sure if I am answering your question, so please let me know if you have any follow up questions.

#3 Updated by Derik Barseghian over 7 years ago

Why is the file use.keplerdata created and included in the installers? Is this a mistake? Its existence can cause Kepler-2.3 to not start.

#4 Updated by Derik Barseghian over 7 years ago

Closing. See bug#5458 for more details, there were many issues involved.

#5 Updated by Redmine Admin about 6 years ago

Original Bugzilla ID was 5473

Also available in: Atom PDF