Project

General

Profile

Bug #5512

Provenance module does not work with MySQL (RecordingException: com.mysql.jbc MysqlDataTruncation)

Added by David LeBauer over 7 years ago. Updated over 7 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
provenance
Target version:
Start date:
10/25/2011
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
5512

Description

After editing Provenance Recorder to store in MySQL, I received the following error:

ptolemy.kernel.util.IllegalActionException: RecordingException: com.mysql.jdbc.MysqlDataTruncation: Data truncation: Data too long for column 'module_dependencies' at row 1
in .pecan.Provenance Recorder
at org.kepler.provenance.ProvenanceRecorder.preinitialize(ProvenanceRecorder.java:544)
at ptolemy.actor.CompositeActor.preinitialize(CompositeActor.java:1363)
at ptolemy.actor.Manager.preinitializeAndResolveTypes(Manager.java:983)
at ptolemy.actor.Manager.initialize(Manager.java:643)
at ptolemy.actor.Manager.execute(Manager.java:340)
at ptolemy.actor.Manager.run(Manager.java:1162)
at ptolemy.actor.Manager$3.run(Manager.java:1215)

The provenanceDB was successfully created and filled out. Bug is not reproduced in a minimal example (perhaps because output is much less). I could do a mysqldump if it would help.

History

#1 Updated by Daniel Crawl over 7 years ago

The following SQL increases the size of the column:

ALTER TABLE workflow_exec MODIFY module_dependencies VARCHAR;

This problem has been fixed, see bug 5302.

#2 Updated by Redmine Admin about 6 years ago

Original Bugzilla ID was 5512

Also available in: Atom PDF