Project

General

Profile

Actions

Bug #5564

closed

dragging sdf director to the canvas causes exception

Added by Jing Tao almost 12 years ago. Updated almost 12 years ago.

Status:
Resolved
Priority:
Normal
Category:
general
Target version:
Start date:
12/06/2011
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
5564

Description

I searched sdf director and got it on the left panel. Then I tried to drag it to the canvas, but i got the exception:
com.microstar.xml.XmlException: Cannot create entity without a class name. in [external stream] at line 2 and column 22
at ptolemy.moml.MoMLParser._checkForNull(MoMLParser.java:3992)
at ptolemy.moml.MoMLParser._createEntity(MoMLParser.java:4173)
at ptolemy.moml.MoMLParser.startElement(MoMLParser.java:2694)
at com.microstar.xml.XmlParser.parseElement(XmlParser.java:922)
at com.microstar.xml.XmlParser.parseContent(XmlParser.java:1105)
at com.microstar.xml.XmlParser.parseElement(XmlParser.java:925)
at com.microstar.xml.XmlParser.parseContent(XmlParser.java:1105)
at com.microstar.xml.XmlParser.parseElement(XmlParser.java:925)
at com.microstar.xml.XmlParser.parseDocument(XmlParser.java:481)
at com.microstar.xml.XmlParser.doParse(XmlParser.java:159)
at com.microstar.xml.XmlParser.parse(XmlParser.java:132)
at ptolemy.moml.MoMLParser.parse(MoMLParser.java:1538)
at ptolemy.moml.MoMLParser.parse(MoMLParser.java:1510)
at ptolemy.moml.MoMLParser.parse(MoMLParser.java:1666)
at ptolemy.moml.MoMLChangeRequest._execute(MoMLChangeRequest.java:289)
at ptolemy.kernel.util.ChangeRequest.execute(ChangeRequest.java:171)
at ptolemy.kernel.util.NamedObj.executeChangeRequests(NamedObj.java:738)
at ptolemy.kernel.util.NamedObj.requestChange(NamedObj.java:1778)
at ptolemy.actor.CompositeActor.requestChange(CompositeActor.java:1922)
at ptolemy.vergil.basic.EditorDropTargetListener.drop(EditorDropTargetListener.java:369)
at java.awt.dnd.DropTarget.drop(DropTarget.java:430)
at sun.awt.dnd.SunDropTargetContextPeer.processDropMessage(SunDropTargetContextPeer.java:500)
at sun.awt.X11.XDropTargetContextPeer.processDropMessage(XDropTargetContextPeer.java:165)
at sun.awt.dnd.SunDropTargetContextPeer$EventDispatcher.dispatchDropEvent(SunDropTargetContextPeer.java:812)
at sun.awt.dnd.SunDropTargetContextPeer$EventDispatcher.dispatchEvent(SunDropTargetContextPeer.java:736)
at sun.awt.dnd.SunDropTargetEvent.dispatch(SunDropTargetEvent.java:30)
at java.awt.Component.dispatchEventImpl(Component.java:4270)
at java.awt.Container.dispatchEventImpl(Container.java:2116)
at java.awt.Component.dispatchEvent(Component.java:4243)
at java.awt.LightweightDispatcher.retargetMouseEvent(Container.java:4322)
at java.awt.LightweightDispatcher.processDropTargetEvent(Container.java:4057)
at java.awt.LightweightDispatcher.dispatchEvent(Container.java:3911)
at java.awt.Container.dispatchEventImpl(Container.java:2102)
at java.awt.Window.dispatchEventImpl(Window.java:2440)
at java.awt.Component.dispatchEvent(Component.java:4243)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:599)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:273)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:183)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:173)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:168)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:160)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:121)


Related issues

Has duplicate Kepler - Bug #5444: Kepler can't run workflow if two instances exist at same timeIn ProgressDaniel Crawl07/29/2011

Actions
Actions #1

Updated by Jing Tao almost 12 years ago

It turns out that i have a another kepler running at my workflow run engine. When i shut it down, the error has gone.

Actions #2

Updated by Christopher Brooks almost 12 years ago

I know this is closed, but the problem is that it appears that there
is a bug if two instances of Kepler are running.

I can't reproduce this, but I'm reopening it because the user should be able
to have two instances of Kepler running.

Jing, can you try to reproduce this?
You are running from the Kepler trunk under what platform?

Actions #3

Updated by Derik Barseghian almost 12 years ago

I recommend closing as duplicate of: bug#5444 (which could be given a more general title)

Actions #4

Updated by Christopher Brooks almost 12 years ago

Good point, bug#5444 includes the same stack trace.
So, I'm closing this one and marking it as a duplicate.

Actions #5

Updated by Redmine Admin over 10 years ago

Original Bugzilla ID was 5564

Actions

Also available in: Atom PDF