Project

General

Profile

Bug #5636

outreach/demos/Database/Database_example_1.xml workflow fails

Added by Derik Barseghian about 10 years ago. Updated about 10 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
general
Target version:
Start date:
06/27/2012
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
5636

Description

I get an error when trying to execute this workflow:

ptolemy.kernel.util.IllegalActionException: fire exception DB connection
in .Database_example_1.Open Database Connection
Because:
java.sql.SQLException: socket creation error
in .Database_example_1.Open Database Connection
at org.geon.OpenDBConnection.fire(OpenDBConnection.java:269)
at ptolemy.actor.AtomicActor.iterate(AtomicActor.java:466)
at ptolemy.actor.sched.StaticSchedulingDirector.fire(StaticSchedulingDirector.java:192)
at ptolemy.actor.CompositeActor.fire(CompositeActor.java:460)
at ptolemy.actor.Manager.iterate(Manager.java:761)
at ptolemy.actor.Manager.execute(Manager.java:352)
at ptolemy.actor.Manager.run(Manager.java:1173)
at ptolemy.actor.Manager$PtolemyRunThread.run(Manager.java:1716)
Caused by: ptolemy.kernel.util.IllegalActionException: java.sql.SQLException: socket creation error
in .Database_example_1.Open Database Connection
at org.geon.OpenDBConnection._connect(OpenDBConnection.java:367)
at org.geon.OpenDBConnection.fire(OpenDBConnection.java:261)
... 7 more
Caused by: ptolemy.kernel.util.IllegalActionException: java.sql.SQLException: socket creation error
in .Database_example_1.Open Database Connection
at org.geon.OpenDBConnection._connect(OpenDBConnection.java:367)
at org.geon.OpenDBConnection.fire(OpenDBConnection.java:261)
at ptolemy.actor.AtomicActor.iterate(AtomicActor.java:466)
at ptolemy.actor.sched.StaticSchedulingDirector.fire(StaticSchedulingDirector.java:192)
at ptolemy.actor.CompositeActor.fire(CompositeActor.java:460)
at ptolemy.actor.Manager.iterate(Manager.java:761)
at ptolemy.actor.Manager.execute(Manager.java:352)
at ptolemy.actor.Manager.run(Manager.java:1173)
at ptolemy.actor.Manager$PtolemyRunThread.run(Manager.java:1716)

History

#1 Updated by jianwu jianwu about 10 years ago

fixed at version 30079.
The reason for the bug is that the default hsql database port has been changed to be 9004 (see bug 5609).

#2 Updated by Redmine Admin over 9 years ago

Original Bugzilla ID was 5636

Also available in: Atom PDF