Project

General

Profile

Bug #565

Balance HTML and enforce 800 width table webpage format

Added by Robert Peet about 17 years ago. Updated over 14 years ago.

Status:
Resolved
Priority:
Normal
Assignee:
Category:
styling
Target version:
Start date:
08/21/2002
Due date:
% Done:

0%

Estimated time:
Bugzilla-Id:
565

Description

1. Webpage headers and footers should be adjusted so that width conforms to the
needs of a 1024 screen setting. There is a bit of overhead in browser margins
and slider bars, so we cannot use the full 1024. My new draft of the index page
has a table width of 971, but nothing special about this.

2. Once we select a table width for headers and footers, we should try to
embed the rest of the text in table cells of hte same maximum width so that we
do not lose aesthetic integrity owning to self-adjusting width of html
rendering. For example, all the text within the ~/vegbranch/vegbranch.html
that has been added moves around as the browser is resized so that the headers
and footers do not appear to fit correctly. Would not be much hassle to
construct all such pages as simple tables.


Related issues

Is duplicate of VegBank - Bug #678: [130] Website cleanup:Table or layer enforcement of formatClosed11/13/2002

History

#1 Updated by Michael Lee about 17 years ago

The larger horizontal screen size was decided against. Leaving this as is.

Changing structure of pages so as to embed a table and prevent text from
extending beyond header and footer still must be completed.

#2 Updated by Michael Lee over 16 years ago

  • Bug 678 has been marked as a duplicate of this bug. ***

#3 Updated by Robert Peet over 16 years ago

I agree

#4 Updated by Michael Lee over 16 years ago

Forcing everything into a 800 wide table would mean that we have to have
balanced html. Which we need to do eventually. So it goes in this bug, too.

What I had previously envisioned was adding to the top of each page, in the
vegbank header token:
<table border="0" width="800"><tr><td>

adding to each footer, via the footer token:
</td></tr></table>

But this will only work if all our html is balanced, which is it not. We need
to balance the html and then attempt this, as this could result in weird
formatting, which sometimes happens in html that isn't balanced (tables beside
one another instead of one below the other)...

#5 Updated by Michael Lee over 14 years ago

width now enforced with new styling

#6 Updated by Redmine Admin over 6 years ago

Original Bugzilla ID was 565

Also available in: Atom PDF